Bug 839884 - Unable to create an application successfully without --nogit option on win7
Unable to create an application successfully without --nogit option on win7
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 02:48 EDT by shjiang
Modified: 2015-05-14 22:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 07:20:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shjiang 2012-07-13 02:48:02 EDT
Description of problem:
Unable to create an application successfully without --nogit option
But create an application with --nogit option first, then git clone can create app sucessfully.


Version-Release number of selected component (if applicable):
Win7 Ruby-1.9
stg.openshift.redhat.com
rhc 0.95.13


How reproducible:
always


Steps to Reproduce:
1.create a namespace;
2.create an app without --nogit option;
3.check the output
  
Actual results:
Now your new domain name is being propagated worldwide (this might take a minute
)...
©[0K    retry # 4 - Waiting for DNS: ruby1-shuiqing.stg.rhcloud.com
Pulling new repo down
git clone --quiet ssh://78c31bf845a34da3b5592db0d10da5b8@ruby1-shuiqing.stg.rhcl
oud.com/~/git/ruby1.git/ ruby1
remote: Counting objects: 25, done.
remote: Compressing objects: 100% (20/20), done.
remote: Total 25 (delta 1), reused 25 (delta 1)Receiving objects:   4% (1/25)
Receiving objects: 100% (25/25), 8.15 KiB, done.

Resolving deltas: 100% (1/1), done.
Non-authoritative answer:
Error in git clone
Cloning into 'ruby1'...
Cleaning up application
Contacting https://stg.openshift.redhat.com


Expected results:
Successfully created application: ruby1


Additional info:
Comment 1 Meng Bo 2012-07-13 06:26:36 EDT
This works for me on my environment.

Windows Version: Windows 7 Ultimate x86
Ruby Version: Ruby 1.9.3 with devkit
Git Version: Git-1.7.11-preview20120710.exe 
rhc Version: rhc-0.95.13
Server: stage-2.0.14


C:\Users\Administrator\Desktop>rhc app create -a php1 -t php-5.3 -p123123 -d
Submitting form:
rhlogin: bmeng@redhat.com
debug: true
Contacting https://stg.openshift.redhat.com
Creating application: php1 in bmengs
Contacting https://stg.openshift.redhat.com
Response from server:
DEBUG:


Exit Code: 0
broker_c: ["namespace", "rhlogin", "ssh", "app_uuid", "debug", "alter", "cartrid
ge", "cart_type", "action", "app_name", "api"]
api_c: ["placeholder"]
API version:    1.1.3
DEBUG: 'php1' creation returned success.
Now your new domain name is being propagated worldwide (this might take a minute
)...
Pulling new repo down
git clone --quiet ssh://f7fcfc081b2944379c55d46e3b5ab5d0@php1-bmengs.stg.rhcloud
.com/~/git/php1.git/ php1
remote: Counting objects: 26, done.
remote: Compressing objects: 100% (20/20), done.
remote: Total 26 (delta 1), reused 26 (delta 1)R
Receiving objects:  23% (6/26)
Receiving objects: 100% (26/26), 7.39 KiB, done.
Resolving deltas: 100% (1/1), done.
Confirming application 'php1' is available
  Attempt # 1
←[0KConfirming application 'php1' is available:  Success!

php1 published:  http://php1-bmengs.stg.rhcloud.com/
git url:  ssh://f7fcfc081b2944379c55d46e3b5ab5d0@php1-bmengs.stg.rhcloud.com/~/g
it/php1.git/
To make changes to 'php1', commit to php1/.
Successfully created application: php1

C:\Users\Administrator\Desktop>gem list

*** LOCAL GEMS ***

archive-tar-minitar (0.5.2)
commander (4.1.2)
highline (1.6.13)
mime-types (1.19)
net-ssh (2.5.2)
rest-client (1.6.7)
rhc (0.95.13)
test-unit (2.5.1)
Comment 2 Xiaoli Tian 2012-07-13 07:20:55 EDT
Can not reproduce as well

Note You need to log in before you can comment on or make changes to this bug.