Bug 839888 - Leading and trailing whitespaces are not stripped in the Seach boxes of Beaker
Summary: Leading and trailing whitespaces are not stripped in the Seach boxes of Beaker
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.9
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.12
Assignee: Raymond Mancy
QA Contact: Qixiang Wan
URL:
Whiteboard: UX
Keywords: FutureFeature
: 912204 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-13 07:00 UTC by Boglarka Ronto
Modified: 2014-12-08 01:13 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-11 04:56:03 UTC


Attachments (Terms of Use)

Description Boglarka Ronto 2012-07-13 07:00:31 UTC
Description of problem:
None of the search boxes labelled "Search" trim leading nor trailing whitespaces, tabs or other non-printable characters.
This would be an extected-to-have feature.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert a string in the search box.
2. Insert the string with a whitespace at the end. 
3. Search will return no results.
  
Actual results:
Empty search results.

Expected results:
Same as when searching for the actual string.

Additional info:
None.

Comment 1 Dan Callaghan 2013-02-18 06:58:21 UTC
*** Bug 912204 has been marked as a duplicate of this bug. ***

Comment 2 Raymond Mancy 2013-02-21 04:07:19 UTC
http://gerrit.beaker-project.org/#/c/1742/

Comment 4 Qixiang Wan 2013-03-26 05:50:49 UTC
Verified with beaker-0.11.3-1.git.187.dac7008.el6.

Search boxes in "Systems" and "Distros" pages are working well with the new build. Leading and trailing whitespaces don't have impact on the search result.

Comment 5 Dan Callaghan 2013-04-11 04:56:03 UTC
Beaker 0.12 has been released.


Note You need to log in before you can comment on or make changes to this bug.