Bug 839952 - NOCpulse throws error every 15minutes if "eth0" is not a device
NOCpulse throws error every 15minutes if "eth0" is not a device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
541
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Milan Zazrivec
Jan Hutař
:
: 875600 (view as bug list)
Depends On:
Blocks: sat550-blockers 819027
  Show dependency treegraph
 
Reported: 2012-07-13 05:38 EDT by Ken Hitchcock
Modified: 2012-11-30 07:01 EST (History)
7 users (show)

See Also:
Fixed In Version: perl-NOCpulse-Gritch-1.27.9-3 MessageQueue-3.26.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 05:17:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Hitchcock 2012-07-13 05:38:30 EDT
Description of problem:
Since Rhel 6.3 eth has been changes to em in the interface options, this in turn has caused NOCpulse throws error every 15minutes if "eth0" is not a device.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. Install RHEL 6
2. Install Satellite 5.4.1
3. Yum update rhel to 6.3
4. Check monitoring emails
  
Actual results:
NOCpulse throws error every 15minutes if "eth0" is not a device

Expected results:
No errors in emails

Additional info:
Comment 1 Clifford Perry 2012-07-17 08:48:19 EDT
Please submit a support request, so that we can correctly triage, replicate, track and associate with your company/organization.

Regards,
Cliff
Comment 2 Michael Mráka 2012-07-25 05:21:59 EDT
This issue has been fixed in Spacewalk 1.6 via bug 768188.
Comment 3 Ken Hitchcock 2012-07-25 10:27:21 EDT
Hi Clifford,

My company is a Red Hat partner but for some reason i don't have the permission to create support tickets. 

I tend to install Satellite quite a bit for customers so i do come across different environments and sometimes uncover bugs. Do i have to go through support every time? 

Hi Michael,

Can you confirm The fixes for Spacewalk will work on satellite 5.4.1 and will not void support from Red Hat?

Thanks
Ken
Comment 4 Clifford Perry 2012-07-25 10:38:00 EDT
(In reply to comment #3)
> Hi Clifford,
> 
> My company is a Red Hat partner but for some reason i don't have the
> permission to create support tickets. 
> 
> I tend to install Satellite quite a bit for customers so i do come across
> different environments and sometimes uncover bugs. Do i have to go through
> support every time? 
> 

If you want the issue to be formally tracked, yes. Customer reported issues are of higher regard than 'random' untriaged/replicated and GSS reviewed/escalated bug reports. 

In this case, we had validation of this bug/issue from Spacewalk and we knew that we had fixed it. 

> Hi Michael,
> 
> Can you confirm The fixes for Spacewalk will work on satellite 5.4.1 and
> will not void support from Red Hat?

Totally unsupported (by Red Hat Support and the Satellite Engineering team) if you manually apply fixes to the current 5.4.1 code base - there has been a lot of other changes. 

We have formal processes, where customers can work with Support for triage/escalation, where needed, to get fixes back-ported to earlier products (though today 5.4.1 is current, 5.5 is to be GA'd soon, fall/autumn 2012).

Regards,
Clifford
Satellite Engineering Manager

> 
> Thanks
> Ken
Comment 11 Clifford Perry 2012-09-21 05:17:05 EDT
This issue is resolved with the release of RHN Satellite 5.5. 

As of September 20th 2012, RHN Satellite 5.5 has been generally available. 

Release Notes and other 5.5 documentation can be found here:

 https://access.redhat.com/knowledge/docs/Red_Hat_Network_Satellite/

The associated Errata for the 5.5 release are:

5.5 Satellite GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1296.html

5.5 Upgrade Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1298.html

5.5 RHN Proxy GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1297.html

5.5 RHN Tools GA Errata
 - http://rhn.redhat.com/errata/RHEA-2012-1299.html

Regards,
Clifford
- Engineering Manager, Satellite
Comment 12 Chandler Wilkerson 2012-11-02 11:31:31 EDT
How about a work-around or patch for those of us who have to go through a long change-management process for something as major as a minor number upgrade?

I'm about to hunt down the script or binary myself and hack it by hand, but I would have expected to find something of use in this thread.
Comment 13 Michael Mráka 2012-11-02 13:49:24 EDT
Hello Chandler,
in the upstream bugzilla (referenced in comment #2) there's list of commits fixing the bug. To see patches just put commit SHA IDs into google search.
Comment 14 Clifford Perry 2012-11-30 07:01:10 EST
*** Bug 875600 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.