Bug 839986 - eclipse-rcp: broken symlinks
eclipse-rcp: broken symlinks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 07:33 EDT by Mikolaj Izdebski
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 18:36:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2012-07-13 07:33:11 EDT
Description of problem:
3 out of 4 symlinks under /usr/share/java/eclipse are broken:
  equinox.http.servlet.jar
  jdt.core.jar
  osgi.services.jar

Version-Release number of selected component (if applicable):
eclipse-rcp-4.2.0-0.22.I201205031800.fc17.x86_64

Steps to Reproduce:
1. yum install eclipse-rcp
2. ls -l /usr/share/java/eclipse
  
Actual results:
3 out of 4 symlinks are broken

Expected results:
no broken symlinks exist

Additional info:
$ stat /usr/share/java/eclipse/jdt.core.jar
  File: `/usr/share/java/eclipse/jdt.core.jar' -> `../../../..//usr/lib64/eclipse/plugins/org.eclipse.jdt.core_3.8.1.v20120502-0834.jar'
  Size: 84        	Blocks: 8          IO Block: 4096   symbolic link
Device: 801h/2049d	Inode: 1050970     Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/    root)   Gid: (    0/    root)
Context: system_u:object_r:usr_t:s0
Access: 2012-07-13 13:22:19.316999946 +0200
Modify: 2012-07-13 13:21:55.869000001 +0200
Change: 2012-07-13 13:21:55.869000001 +0200
 Birth: -

$ stat /usr/lib64/eclipse/plugins/org.eclipse.jdt.core_3.8.1.v20120502-0834.jar
stat: cannot stat `/usr/lib64/eclipse/plugins/org.eclipse.jdt.core_3.8.1.v20120502-0834.jar': No such file or directory

$ rpm -qf /usr/share/java/eclipse/jdt.core.jar
eclipse-rcp-4.2.0-0.22.I201205031800.fc17.x86_64
Comment 1 Krzysztof Daniel 2012-07-13 08:22:46 EDT
It works for me:

[kdaniel@kdanielX220Fedora eclipse]$ pwd
/usr/share/java/eclipse
[kdaniel@kdanielX220Fedora eclipse]$ rpm -qa | grep -e "eclipse-platform-[0-9].*"
eclipse-platform-4.2.0-1.I201206081400.fc18.x86_64
[kdaniel@kdanielX220Fedora eclipse]$ ls -l
total 20
lrwxrwxrwx. 1 root root 98 Jun 29 11:41 equinox.http.servlet.jar -> ../../../..//usr/lib64/eclipse/plugins/org.eclipse.equinox.http.servlet_1.1.300.v20120522-1841.jar
lrwxrwxrwx. 1 root root 84 Jun 29 11:41 jdt.core.jar -> ../../../..//usr/lib64/eclipse/plugins/org.eclipse.jdt.core_3.8.1.v20120531-0637.jar
lrwxrwxrwx. 1 root root 80 Jun 29 11:41 osgi.jar -> ../../../..//usr/lib64/eclipse/plugins/org.eclipse.osgi_3.8.0.v20120529-1548.jar
lrwxrwxrwx. 1 root root 91 Jun 29 11:41 osgi.services.jar -> ../../../..//usr/lib64/eclipse/plugins/org.eclipse.osgi.services_3.3.100.v20120522-1822.jar
lrwxrwxrwx. 1 root root 87 Jun 29 11:41 osgi.util.jar -> ../../../..//usr/lib64/eclipse/plugins/org.eclipse.osgi.util_3.2.300.v20120522-1822.jar

Please reopen if you find it broken in latest Juno release.
Comment 2 Krzysztof Daniel 2012-07-17 05:24:22 EDT
Reopening for investigation as per report on irc.
Comment 3 Mikolaj Izdebski 2012-07-17 07:15:17 EDT
In rawhide symlinks are fine now.
Comment 4 Krzysztof Daniel 2012-07-17 07:48:27 EDT
(In reply to comment #3)
> In rawhide symlinks are fine now.

that's nice, but I think I found a bug :-)
Comment 5 Fedora Update System 2012-07-17 08:59:06 EDT
eclipse-4.2.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/eclipse-4.2.0-3.fc17
Comment 6 Fedora Update System 2012-07-19 05:09:05 EDT
Package eclipse-4.2.0-3.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-4.2.0-3.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10831/eclipse-4.2.0-3.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-07-26 18:36:58 EDT
eclipse-4.2.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.