Bug 839992 - Problem with r8169 NIC driver ( RTL8168b/8111b)
Problem with r8169 NIC driver ( RTL8168b/8111b)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 07:50 EDT by Łukasz Trąbiński
Modified: 2012-09-07 16:49 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 16:49:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Full dmesg from boot (70.27 KB, text/plain)
2012-07-13 09:41 EDT, Łukasz Trąbiński
no flags Details
Dmesg from running system (72.30 KB, text/plain)
2012-07-13 12:59 EDT, Łukasz Trąbiński
no flags Details

  None (edit)
Description Łukasz Trąbiński 2012-07-13 07:50:35 EDT
Description of problem:

Problem with r8169 NIC driver

Version-Release number of selected component (if applicable):

kernel-3.4.4-5.fc17.x86_64


How reproducible:

Install kernel-3.4.4-5.fc17.x86_64


Steps to Reproduce:
1. install or upgrade to FC17 on system with  RTL8168b/8111b
2. install kernel-3.4.4-5.fc17.x86_64
3. Let traffic through eth0
  
Actual results:

Interface eth0 works like below (with 5-10 secunds interruption)


Jul 13 11:59:08 mask kernel: [167214.997570] r8169 0000:02:00.0: eth0: link up
Jul 13 12:54:44 mask kernel: [170544.988998] r8169 0000:02:00.0: eth0: link up
Jul 13 13:30:56 mask kernel: [172713.075974] r8169 0000:02:00.0: eth0: link up
Jul 13 13:33:44 mask kernel: [172880.773306] r8169 0000:02:00.0: eth0: link up
Jul 13 13:36:02 mask kernel: [173018.524684] r8169 0000:02:00.0: eth0: link up
Jul 13 13:36:14 mask kernel: [173030.503068] r8169 0000:02:00.0: eth0: link up
Jul 13 13:36:26 mask kernel: [173042.481441] r8169 0000:02:00.0: eth0: link up



Expected results:


Additional info:
Comment 1 Josh Boyer 2012-07-13 09:22:39 EDT
Did this just start with 3.4.4-5.fc17, or have you noticed it with previous kernels?

Can you attach the full dmesg for that boot please?
Comment 2 Łukasz Trąbiński 2012-07-13 09:41:25 EDT
Created attachment 598076 [details]
Full dmesg from boot

Full dmesg from boot
Comment 3 Łukasz Trąbiński 2012-07-13 09:42:22 EDT
Previously we used kernel-2.6.43.8-1.fc15.x86_64 on FC15. Two days ago we done upgrade to FC17.
Comment 4 Josh Boyer 2012-07-13 10:13:27 EDT
(In reply to comment #2)
> Created attachment 598076 [details]
> Full dmesg from boot
> 
> Full dmesg from boot

I meant the dmesg for the boot showing the issues in the original comment.  This seems to be a fresh reboot.  I was curious if there were other messages in dmesg pertaining to the eth0 device other than just the link up ones.
Comment 5 Łukasz Trąbiński 2012-07-13 12:59:36 EDT
Created attachment 598114 [details]
Dmesg from running system

OK, here is full dmesg from running system.
Comment 6 Łukasz Trąbiński 2012-07-23 04:57:30 EDT
Hi
I have just changed kernel to  3.4.6-2.fc17.x86_64, and after 30 minutes I got Ooops. I don't know that is related with NIC flap but I send it here, maybe it can by helpful for future debugging.


[root@mask ~]# dmesg
[ 3541.451917] ------------[ cut here ]------------
[ 3541.451993] WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x250/0x260()
[ 3541.452079] Hardware name: GA-MA790FX-DQ6
[ 3541.452128] NETDEV WATCHDOG: eth0 (r8169): transmit queue 0 timed out
[ 3541.452203] Modules linked in: nfsd nfs_acl auth_rpcgss lockd sunrpc snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm edac_core edac_mce_amd snd_page_alloc r8169 snd_timer snd soundcore mii ppdev sp5100_tco k10temp i2c_piix4 parport_pc parport microcode firewire_ohci firewire_core ata_generic raid10 crc_itu_t pata_atiixp pata_acpi pata_jmicron wmi radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
[ 3541.452783] Pid: 0, comm: swapper/2 Not tainted 3.4.6-2.fc17.x86_64 #1
[ 3541.452860] Call Trace:
[ 3541.452892]  <IRQ>  [<ffffffff81056ecf>] warn_slowpath_common+0x7f/0xc0
[ 3541.452996]  [<ffffffff81056fc6>] warn_slowpath_fmt+0x46/0x50
[ 3541.453068]  [<ffffffff81505ac0>] dev_watchdog+0x250/0x260
[ 3541.453144]  [<ffffffff81505870>] ? dev_deactivate_queue.constprop.30+0x80/0x80
[ 3541.453150]  [<ffffffff810660a1>] run_timer_softirq+0x141/0x340
[ 3541.453155]  [<ffffffff8105e2a0>] __do_softirq+0xc0/0x1e0
[ 3541.453162]  [<ffffffff8101a8d3>] ? native_sched_clock+0x13/0x80
[ 3541.453169]  [<ffffffff815fe0dc>] call_softirq+0x1c/0x30
[ 3541.453174]  [<ffffffff81015255>] do_softirq+0x75/0xb0
[ 3541.453178]  [<ffffffff8105e675>] irq_exit+0xb5/0xc0
[ 3541.453182]  [<ffffffff815fea1e>] smp_apic_timer_interrupt+0x6e/0x99
[ 3541.453187]  [<ffffffff815fd78a>] apic_timer_interrupt+0x6a/0x70
[ 3541.453190]  <EOI>  [<ffffffff81066d51>] ? get_next_timer_interrupt+0x1e1/0x270
[ 3541.453199]  [<ffffffff8103de46>] ? native_safe_halt+0x6/0x10
[ 3541.453203]  [<ffffffff8101b82f>] default_idle+0x4f/0x1a0
[ 3541.453207]  [<ffffffff8101b9dd>] amd_e400_idle+0x5d/0x120
[ 3541.453211]  [<ffffffff8101c56e>] cpu_idle+0xfe/0x120
[ 3541.453217]  [<ffffffff815e3bab>] start_secondary+0x248/0x24a
[ 3541.453220] ---[ end trace f56b93336ec2da2e ]---
[ 3541.458043] r8169 0000:02:00.0: eth0: link up
[ 3553.439410] r8169 0000:02:00.0: eth0: link up
Comment 7 Łukasz Trąbiński 2012-09-07 04:51:36 EDT
Hi
With kernel 3.5.1-1.fc17.x86_64 ethernet card works ok without problems.
Comment 8 Olle Liljenzin 2012-09-07 05:41:08 EDT
> With kernel 3.5.1-1.fc17.x86_64 ethernet card works ok without problems.

What link speed and duplex do you get? I just filed bug 855299 and it would be interesting to know if other people experience the same problem.
Comment 9 Łukasz Trąbiński 2012-09-07 05:46:51 EDT
I had the same problem with older kernels like 3.4.4-5.fc17.x86_64

Now, with 3.5.1-1 it works ok.

[root@mask ~]# ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                             100baseT/Half 100baseT/Full
                                             1000baseT/Full
        Link partner advertised pause frame use: No
        Link partner advertised auto-negotiation: Yes
        Speed: 1000Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 0
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000033 (51)
                               drv probe ifdown ifup
        Link detected: yes

Note You need to log in before you can comment on or make changes to this bug.