Bug 840 - acroread dumps core in netscape
acroread dumps core in netscape
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-15 08:39 EST by m.a.hulsen
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-01-22 11:56:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description m.a.hulsen 1999-01-15 08:39:56 EST
When I add acroread (version3.02) to the applications in
 netscape for reading pdf files acroread dumps core after
 the download of the pdf file. When reading the pdf file
 outside netscape everything is fine. The problem occurs
 with all versionsof netscape 4.07, 4.08 and 4.5. It did not
 occur with previous versions of netscape/redhat releases
 I know of.(rh4.2, rh5.1).
Comment 1 Bill Nottingham 1999-01-15 10:42:59 EST
you're launching libc5 acroread from glibc2 netscape. There's
probably library confusion somewhere. Look at the acroread
binary; IIRC, it's a shell script. I believe there's a line
in it that sets "LD_LIBRARY_PATH"; add "/usr/i486-linux-libc5/lib"
to the beginning of that path. Does that help?
Comment 2 Aleksey Nogin 1999-01-15 22:05:59 EST
I had this problem too. It turned out that /usr/bin/netscape sets
LD_PRELOAD environment variable to be /lib/libBrokenLocale.so.1,
acroread inherits it, tries to preload this library and crashes
because of that.

My workaround was to write a small shell script:

#!/bin/sh
unset LD_PRELOAD
exec /usr/local/Acrobat3/bin/acroread $*

and to specify that script in Preferences|Navigator|Applications
Comment 3 m.a.hulsen 1999-01-17 05:01:59 EST
This workaround solves the problem indeed! Thanks.
Comment 4 Aleksey Nogin 1999-01-18 18:56:59 EST
Why was this bug discarded? The problem still exists and it is caused
by the /usr/bin/netscape script written by RedHat. The only
application known to suffer from this is Acroread, but probably some
other application would also crash because of this unexpected
LD_PRELOAD.
Comment 5 m.a.hulsen 1999-01-22 10:52:59 EST
I already found a new one suffering from this: the citrix
(www.citrix.com) icaclient (wfica) for running windows applications on
a remote NT machine. I need this client to access databases in our
library. Making a similar script unsetting LD_PRELOAD fixes it again,
however this is an unsatisfactory situation. It should be fixed in the
netscape script.
Comment 6 Bill Nottingham 1999-01-22 11:56:59 EST
The LD_PRELOAD in netscape was needed in previous versions
to fix a locale problem with netscape. It's no longer necessary
in recent versions of netscape.

Fixed in 4.08-5.

Note You need to log in before you can comment on or make changes to this bug.