Bug 840009 - rule6-* files are ignored for sit devices
Summary: rule6-* files are ignored for sit devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-13 12:48 UTC by David Kostal
Modified: 2016-11-25 13:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 22:10:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix for ifup-sit/ifdown-sit scripts to process rule6-* files (1.46 KB, patch)
2012-07-13 12:48 UTC, David Kostal
no flags Details | Diff
use ip{up,down}-routes with sit (1.08 KB, patch)
2012-08-07 10:48 UTC, Lukáš Nykrýn
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1679 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2013-11-20 21:52:39 UTC

Description David Kostal 2012-07-13 12:48:18 UTC
Created attachment 598065 [details]
Fix for ifup-sit/ifdown-sit scripts to process rule6-* files

Description of problem:
When activating IP6 over IP4 tunnel, the route6-* files are processed but rule6-* are not.

Version-Release number of selected component (if applicable):
9.03.27-1.el6

How reproducible:
allways when starting/stopping IP6 tunnel via ifup/ifdown scripts

Steps to Reproduce:
1. create /etc/sysconfig/network-scripts/ifcfg-he6 as TYPE=sit and file etc/sysconfig/network-scripts/rule6-he6 with proper rules.
2. ifup he6
3. 
  
Actual results:
"ip -6 ru ls" does NOT show rules defined in rule6-he6 file

Expected results:
"ip -6 ru ls" should show rules rules defined in rule6-he6 file

Additional info:
Adding ip6 rules works for regular interfaces (eg. eth0). Patch fixing this issue is attached.

Comment 2 Lukáš Nykrýn 2012-08-01 08:14:11 UTC
Thanks for the patch, I see no reason why not to include it.

Comment 4 Lukáš Nykrýn 2012-08-07 10:48:55 UTC
Created attachment 602716 [details]
use ip{up,down}-routes with sit

Bill suggested that we should use ifup-routes and ifdown-routes. Can you please try attached patch?

Comment 5 David Kostal 2012-08-07 11:46:48 UTC
The new patch works well for me. Thanks!

Comment 7 Lukáš Nykrýn 2013-04-02 16:52:38 UTC
upstream commit d232acc90d7ebc2beba5e4ef6f9ffa6ab7f9b795

Comment 15 errata-xmlrpc 2013-11-21 22:10:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1679.html


Note You need to log in before you can comment on or make changes to this bug.