Bug 840011 - Plugins configuration is not re-read after close-open of Preferences dialog
Plugins configuration is not re-read after close-open of Preferences dialog
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dconf (Show other bugs)
7.0
All Unspecified
low Severity medium
: beta
: 7.0
Assigned To: Marek Kašík
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 08:55 EDT by Martin
Modified: 2014-09-14 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:23:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin 2012-07-13 08:55:10 EDT
Description of problem:

Plugins configuration is not re-read after close-open of Preferences dialog.

When I run 2 instances of Gnome application like Gedit or Totem plugins configuration dialogs doesn't reflect changes between multiple application instances like other configuration options/tabs do. This should be consistent with other Properties tabs where configuration is being reread after each time configuration dialog is (re)opened.

Version-Release number of selected component (if applicable):
gtk3-3.4.3-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
0. Run 2 Gedit instances on 2 machines with shared home.
1. Choose "Edit" - "Preferences" in first Gedit instance and select "Plugins" tab. Then enable "Quick Open" plugin and click "Close".
2. Choose "Edit" - "Preferences" in second Gedit instance and select "Plugins" tab.

Actual results:
Plugins configuration dialog in second Gedit instance does not reflect changes did on first Gedit instance. "Quick Open" plugin is disabled.

Expected results:
"Quick Open" plugin should be enabled.

Additional info:
All configuration changes should be consistent and predictable when running multiple application instances.
Comment 2 Cosimo Cecchi 2012-07-13 09:46:50 EDT
There is a shared component in the plugin system of those two applications: libpeas. EOG uses it as well it, can you confirm the bug is reproducible there as well?
Anyway, it looks to me that the plugin configuration is stored as a GSettings key, so I suspect this is due to dconf still missing full support for NFS home directories. Such support is supposed to land upstream this cycle, so we'll see if that helps with this specific situation.

Reassigning to libpeas for the moment.
Comment 3 Martin 2012-07-13 10:26:04 EDT
I can reproduce this bug in EOG.
Comment 4 Bastien Nocera 2012-10-16 12:38:08 EDT
If we DConf doesn't update GSettings on the other machine, there's nothing libpeas can do.
Comment 12 Ludek Smid 2014-06-13 07:23:49 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.