Bug 840080 - ovirt-config-password can not be used to set admin password
ovirt-config-password can not be used to set admin password
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 12:00 EDT by Fabian Deutsch
Modified: 2016-04-26 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 21:27:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2012-07-13 12:00:08 EDT
Description of problem:
o-c-password fails with a "token manipulation error" if it's used to set the admin password.

Version-Release number of selected component (if applicable):
A recent F17 build

How reproducible:
Always

Steps to Reproduce:
1. Install F17 using auto install (don't know yet if ai is relevant)
2. Login and drop to shell
3. run /usr/libexec/ovirt-config-password
  
Actual results:
Password can not be set because passwd fails with "token manipulation error"

Expected results:
Password can be set

Additional info:
It seems that passwd changed, strace reveals that it tries to rename /etc/nshadow to /etc/shadow, this fails on our (ro) setup
Comment 1 Fabian Deutsch 2012-07-13 12:02:31 EDT
The ovirtnode.password py-module is not affected and can be used to change the password (so TUI is not affected)
Comment 2 Fabian Deutsch 2012-07-19 07:49:22 EDT
Proposed patch:

http://gerrit.ovirt.org/#/c/6454/

Tests are pending.
Comment 3 Joey Boggs 2013-02-01 21:27:00 EST
patch was merged in July, works in current release

Note You need to log in before you can comment on or make changes to this bug.