Bug 840087 - Unable to boot rhev-hypervisor6.iso in virtual machine for testing.
Unable to boot rhev-hypervisor6.iso in virtual machine for testing.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vgabios (Show other bugs)
6.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
: Regression
: 906697 (view as bug list)
Depends On:
Blocks: 867404
  Show dependency treegraph
 
Reported: 2012-07-13 12:10 EDT by Stephen Gordon
Modified: 2016-04-26 11:09 EDT (History)
21 users (show)

See Also:
Fixed In Version: vgabios-0.6b-3.7.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 867404 (view as bug list)
Environment:
Last Closed: 2013-02-21 06:02:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2012-07-13 12:10:23 EDT
Description of problem:

At some point it has become impossible to boot the hypervisor ISO in a Virtual Machine, a common requirement for testing. When starting a virtual machine using the ISO the boot menu appears but the virtual machine becomes frozen on it as soon as an option is chosen. No further input appears to be accepted.

I've tested this both in virtual machines hosted on RHEV 3.0 and on my laptop with F17 (virt-manager etc.) to no avail. 

Version-Release number of selected component (if applicable):

rhev-hypervisor6-6.3-20120710.0.el6_3.noarch.rpm
Comment 4 haiyang,dong 2012-07-19 05:06:47 EDT
Test on rhev-hypervisor6-6.3-20120710.0.el6_3 build,if set console of server virtual Machine with protocol "VNC",can boot rhev-hypervisor6.iso in virtual machine,but failed with protocol "Spice"
Comment 5 Stephen Gordon 2012-07-19 10:29:27 EDT
(In reply to comment #4)
> Test on rhev-hypervisor6-6.3-20120710.0.el6_3 build,if set console of server
> virtual Machine with protocol "VNC",can boot rhev-hypervisor6.iso in virtual
> machine,but failed with protocol "Spice"

I switched mine to VNC (from SPICE) and still appear to have the same issue.
Comment 6 Stephen Gordon 2012-09-05 10:03:48 EDT
OK. I have done some further testing, I found that with the VNC display and the 'vga' graphics adaptor selected I got the same behaviour as with SPICE/'qxl' - the virtual machine froze.

If I switch the display type to VNC *and* the virtual graphics adaptor from 'qxl' to 'cirrus' the virtual machine boots correctly.
Comment 7 Mike Burns 2012-09-13 09:59:45 EDT
Looks like this is spice related so moving to spice-client.  If it turns out that it needs a fix in rhev-h, please assign back
Comment 8 David Jaša 2012-09-13 11:02:48 EDT
(In reply to comment #6)
> OK. I have done some further testing, I found that with the VNC display and
> the 'vga' graphics adaptor selected I got the same behaviour as with
> SPICE/'qxl' - the virtual machine froze.
> 
> If I switch the display type to VNC *and* the virtual graphics adaptor from
> 'qxl' to 'cirrus' the virtual machine boots correctly.

looks like vgabios issue. Steve, could you post your seabios and vgabios versions from the hosts and name-version of RHEV-H bootloader?
Comment 9 Stephen Gordon 2012-09-13 12:15:50 EDT
On my desktop machine:

vgabios-0.6c-4.fc17.noarch
seabios-bin-1.7.0-1.fc17.noarch

Most recent RHEV-H image I tested this on was this, so whatever bootloader was included in the image:

rhevh-6.3-20120710.0.el6_3.iso
Comment 10 David Jaša 2012-09-13 12:29:36 EDT
Reassigning to vgabios because both vga/vnc and qxl/spice combinations are affected.
Comment 11 RHEL Product and Program Management 2012-09-13 12:49:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 12 Gerd Hoffmann 2012-10-17 02:57:06 EDT
Patch posted.

Workaround: Hit 'tab', remove "quiet" from the args, boot.
Comment 14 RHEL Product and Program Management 2012-10-22 05:39:49 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 20 Chao Yang 2012-12-20 03:55:10 EST
Reproduced this bug with vgabios-0.6b-3.6.el6.noarch.rpm

Steps:
1. boot a guest with qxl+spice from ISO provided by rhev-hypervisor6-6.3-20121212.0.el6_3.noarch
2. at boot menu phase, hit enter on any option

Actual Result:
Guest hanged

Verified with vgabios-0.6b-3.7.el6.noarch. NO hang and installation could be finished with same steps above.

As per above, this issue has been fixed.
Comment 23 errata-xmlrpc 2013-02-21 06:02:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0487.html
Comment 24 Hans de Goede 2013-07-02 06:42:09 EDT
*** Bug 906697 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.