Bug 840116 - systemctl enable kdump.service errors out
systemctl enable kdump.service errors out
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 14:58 EDT by joshua
Modified: 2013-02-25 03:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 03:51:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-07-13 14:58:54 EDT
Description of problem:

After enabling kdump via grub and kdump.conf, I type this and get this error:

#systemctl enable kdump.service
The unit files have no [Install] section. They are not meant to be enabled using systemctl.


So what does this mean?  Is the kexec-tools package missing something that systemctl needs to run?





Version-Release number of selected component (if applicable):

Fedora 17 x86_64
Comment 1 joshua 2012-07-13 15:05:50 EDT
Sorry, using these packages:

kernel-3.4.4-5.fc17.x86_64
kexec-tools-2.0.3-38.fc17.x86_64
systemd-44-17.fc17.x86_64
Comment 2 joshua 2012-07-13 15:12:00 EDT
Jul 13 15:08:43 mb06-002 kdump: No crashkernel parameter specified for running kernel
Jul 13 15:08:43 mb06-002 kdumpctl[8861]: Starting kdump:
Jul 13 15:08:43 mb06-002 kdump: failed to start up
Jul 13 15:08:43 mb06-002 systemd[1]: kdump.service: main process exited, code=exited, status=1
Job failed. See system journal and 'systemctl status' for details.
Jul 13 15:08:43 mb06-002 systemd[1]: Unit kdump.service entered failed state.
Comment 3 Dave Young 2012-07-22 22:26:47 EDT
(In reply to comment #2)
> Jul 13 15:08:43 mb06-002 kdump: No crashkernel parameter specified for
> running kernel
> Jul 13 15:08:43 mb06-002 kdumpctl[8861]: Starting kdump:
> Jul 13 15:08:43 mb06-002 kdump: failed to start up
> Jul 13 15:08:43 mb06-002 systemd[1]: kdump.service: main process exited,
> code=exited, status=1
> Job failed. See system journal and 'systemctl status' for details.
> Jul 13 15:08:43 mb06-002 systemd[1]: Unit kdump.service entered failed state.

Hi, Have you tried systemctl enable kdump.service? is it ok?

Above message just means the service failed startup due to no crashkernel= cmdline in grub conf.
Comment 4 joshua 2012-07-23 13:54:25 EDT
Sorry, I shouldn't have confused the issue with Comment #2.

I do have crashkernel=128M in grub2.conf:

# cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-3.4.4-5.fc17.x86_64 root=/dev/mapper/VolGrp01-root_fs ro rd.lvm.lv=VolGrp01/swap rd.md=0 rd.dm=0 SYSFONT=True KEYTABLE=us 
rd.lvm.lv=VolGrp01/root_fs rd.luks=0 LANG=en_US.UTF-8 crashkernel=128M quiet 

... and still:

# systemctl enable kdump.service
The unit files have no [Install] section. They are not meant to be enabled using systemctl.


"chkconfig kdump on" doesn't work either ... so how is one supposed to ensure that the kdump service starts at boot?
Comment 5 Dave Young 2012-07-23 22:41:44 EDT
(In reply to comment #4)
> # systemctl enable kdump.service
> The unit files have no [Install] section. They are not meant to be enabled
> using systemctl.

Oh, sorry, you are using 2.0.3-38, the fix got merged in 2.0.3-40, please download latest f17 version from below url:

http://kojipkgs.fedoraproject.org//packages/kexec-tools/2.0.3/
Comment 6 joshua 2012-07-24 17:03:40 EDT
Yes!  http://kojipkgs.fedoraproject.org//packages/kexec-tools/2.0.3/47.fc17.1/x86_64/kexec-tools-2.0.3-47.fc17.1.x86_64.rpm does much better:

# systemctl enable kdump.service
ln -s '/usr/lib/systemd/system/kdump.service' '/etc/systemd/system/multi-user.target.wants/kdump.service'

When can we get this is Fedora 17?
Comment 7 Dave Young 2012-07-24 22:21:21 EDT
just upgrade it with yum should work.
'yum upgrade kexec-tools'
Comment 8 joshua 2012-07-26 17:00:31 EDT
I'm not finding this to be true.  It isn't in the regular Fedora 17 86_64 update repos.
Comment 9 Dave Young 2012-07-29 22:29:17 EDT
(In reply to comment #8)
> I'm not finding this to be true.  It isn't in the regular Fedora 17 86_64
> update repos.

Hi, could you try again? I have manually set it as stable.
Comment 10 joshua 2012-07-30 15:23:05 EDT
Yes!  That did it, thank you
Comment 11 Fedora Admin XMLRPC Client 2013-02-25 03:08:13 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 12 Fedora Admin XMLRPC Client 2013-02-25 03:10:17 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.