Bug 840155 - SELinux is preventing /usr/libexec/kde4/ksysguardprocesslist_helper from 'write' accesses on the directory /.config.
SELinux is preventing /usr/libexec/kde4/ksysguardprocesslist_helper from 'wri...
Status: CLOSED DUPLICATE of bug 694385
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:893fe7b550f7d1ac0dc45f3e25e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-13 18:28 EDT by Dartagnan
Modified: 2012-07-15 14:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-15 14:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dartagnan 2012-07-13 18:28:54 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.4.4-5.fc17.i686
time:           Fri 13 Jul 2012 09:47:05 AM MDT

description:
:SELinux is preventing /usr/libexec/kde4/ksysguardprocesslist_helper from 'write' accesses on the directory /.config.
:
:*****  Plugin catchall_labels (83.8 confidence) suggests  ********************
:
:If you want to allow ksysguardprocesslist_helper to have write access on the .config directory
:Then you need to change the label on /.config
:Do
:# semanage fcontext -a -t FILE_TYPE '/.config'
:where FILE_TYPE is one of the following: root_t. 
:Then execute: 
:restorecon -v '/.config'
:
:
:*****  Plugin catchall (17.1 confidence) suggests  ***************************
:
:If you believe that ksysguardprocesslist_helper should be allowed write access on the .config directory by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep ksysguardproces /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:gnomesystemmm_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:default_t:s0
:Target Objects                /.config [ dir ]
:Source                        ksysguardproces
:Source Path                   /usr/libexec/kde4/ksysguardprocesslist_helper
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ksysguard-4.8.4-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-137.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.4.4-5.fc17.i686 #1 SMP Thu Jul 5
:                              20:17:29 UTC 2012 i686 i686
:Alert Count                   2
:First Seen                    Fri 13 Jul 2012 07:04:53 AM MDT
:Last Seen                     Fri 13 Jul 2012 09:29:00 AM MDT
:Local ID                      fc2b1d33-aadf-459c-a218-0e583ea618b3
:
:Raw Audit Messages
:type=AVC msg=audit(1342193340.460:145): avc:  denied  { write } for  pid=5461 comm="ksysguardproces" name=".config" dev="dm-1" ino=1048577 scontext=system_u:system_r:gnomesystemmm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:default_t:s0 tclass=dir
:
:
:type=SYSCALL msg=audit(1342193340.460:145): arch=i386 syscall=open success=no exit=EACCES a0=9721300 a1=880c2 a2=180 a3=0 items=0 ppid=1 pid=5461 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=ksysguardproces exe=/usr/libexec/kde4/ksysguardprocesslist_helper subj=system_u:system_r:gnomesystemmm_t:s0-s0:c0.c1023 key=(null)
:
:Hash: ksysguardproces,gnomesystemmm_t,default_t,dir,write
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-15 14:14:12 EDT
This is KDE bug.

You can allow it for now using

# semanage fcontext -a -e /usr/share/config /.config
# restorecon -R -v /.config

*** This bug has been marked as a duplicate of bug 694385 ***

Note You need to log in before you can comment on or make changes to this bug.