Bug 840295 - SetupNetworks | Can't attache VLAN network when VM_NET with IP attached to interface.
SetupNetworks | Can't attache VLAN network when VM_NET with IP attached to in...
Status: CLOSED DUPLICATE of bug 837789
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Alona Kaplan
Meni Yakove
network
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 09:37 EDT by Meni Yakove
Modified: 2016-02-10 14:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 05:11:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (352.41 KB, application/octet-stream)
2012-07-15 09:37 EDT, Meni Yakove
no flags Details

  None (edit)
Description Meni Yakove 2012-07-15 09:37:35 EDT
Created attachment 598307 [details]
engine.log

Description of problem:
Attach VM_NET to interface and assign IP, Whan try to add VLAN to the same interface I get error:
CanDoAction of action SetupNetworks failed. Reasons:VAR__ACTION__SETUP,VAR__TYPE__NETWORKS,,NETWROK_ADDR_MANDATORY_IN_STATIC_IP

Version-Release number of selected component (if applicable):
rhevm-3.1.0-6.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.Open SetupNetwork and attach VM_NET to interface(eth0) and assing IP to VM_NET, Apply
2.Open SetupNetwork and attache VLAN network to the same insterface(eth0), Apply

  
Actual results:
Failed to apply, ERROR: Netwrok address must be specify when using static ip
The VLAN network isn't attached to the interface.
Expected results:
VLAN network attached to interface with VM_NET.

Additional info:
Comment 2 lpeer 2012-07-22 02:11:17 EDT
I agree with Simon, if VM_NET is a VM network then the issue in this bug is the wrong error message.

Meni - Can you please confirm -

Is VM_NET a VM network?
Comment 4 Meni Yakove 2012-07-25 04:24:46 EDT
The VM_NET is bridge network and its VLAN tag.
Comment 5 lpeer 2012-07-25 05:08:06 EDT
The issue in this bug is that we should block this topology from security reasons.
We do not support vlaned network and non-vlan+bridged network on the same NIC.

This bug is not a regression as we did not support vlan and non-vlan network on the same nic in 3.0.
Comment 6 lpeer 2012-07-25 05:11:20 EDT
actually this is duplicate of 837789

*** This bug has been marked as a duplicate of bug 837789 ***

Note You need to log in before you can comment on or make changes to this bug.