Bug 840324 - glines Receives Segmentation Fault
glines Receives Segmentation Fault
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
18
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 17:28 EDT by William Makowski
Modified: 2013-12-05 10:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 10:46:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glines stack trace (2.05 KB, text/plain)
2012-07-15 17:28 EDT, William Makowski
no flags Details
backtrace from glines seg fault (6.32 KB, text/plain)
2013-01-12 20:15 EST, William Makowski
no flags Details
Proposed Patch for F17 (745 bytes, patch)
2013-03-18 12:05 EDT, William Makowski
no flags Details | Diff
Proposed Patch for F18 (469 bytes, patch)
2013-03-18 12:08 EDT, William Makowski
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 675628 None None None Never
Launchpad 995281 None None None Never

  None (edit)
Description William Makowski 2012-07-15 17:28:49 EDT
Created attachment 598333 [details]
glines stack trace

Description of problem: 
When glines is executed it receives a Segmentation fault. The game does not come up when run from the menu. I ran from the command line to see what was happening and received the Segmentation fault message.

Version-Release number of selected component (if applicable):
gnome-games-extra-3.4.2-1.fc17.i686

How reproducible:
Happens every time /usr/bin/glines is executed.

Steps to Reproduce:
1. Run /usr/bin/glines via menu or command line.
  
Actual results:
Game does not come up.

Expected results:
Game should come up and be ready to play.

Additional info:
I'm including a stack trace as an attachement. This was obtained using gdb.
Comment 1 William Makowski 2012-08-26 10:41:33 EDT
Still broke, but getting rid of the computer where it is an issue.
Comment 2 William Makowski 2013-01-12 20:09:05 EST
Have confirmed that glines is still getting a segmentation fault on another install.  This bug has been reported upstream at Gnome (see external tracker above) and at Ubuntu.

https://bugs.launchpad.net/ubuntu/+source/gnome-games/+bug/995281

There is a patch proposed at ubuntu that solved the problem for me.

https://launchpadlibrarian.net/106290229/04_fix-segfault.patch
Comment 3 William Makowski 2013-01-12 20:15:52 EST
Created attachment 677601 [details]
backtrace from glines seg fault
Comment 4 William Makowski 2013-01-19 11:20:32 EST
Changing version to Fedora 18. This is still a issue in gnome-games-glines-3.6.1-1.fc18.i686.
Comment 5 Guillermo Gómez 2013-02-24 16:10:39 EST
Hmm... gnome-games-glines.x86_64 1:3.6.1-1.fc18 seems to work fine here.
Comment 6 William Makowski 2013-03-18 09:32:23 EDT
glines continues to receive a segmentation fault in the latest update.

gnome-games-glines-3.6.1-2.fc18.i686
Comment 7 William Makowski 2013-03-18 12:05:13 EDT
Created attachment 712081 [details]
Proposed Patch for F17

Patch provided by previously referenced bug.

https://bugs.launchpad.net/ubuntu/+source/gnome-games/+bug/995281
Comment 8 William Makowski 2013-03-18 12:08:50 EDT
Created attachment 712082 [details]
Proposed Patch for F18

glines.c changes a little between F17 and F18. Here is the patch I have been using.
Comment 9 William Makowski 2013-12-05 10:46:47 EST
Closing, fixed in F19 with five-or-more-3.8.2-2.fc19.i686. Always happy to report problems and supply patches for myself.

Note You need to log in before you can comment on or make changes to this bug.