Bug 840370 - Non-top snap shot of VM disk can not be deleted
Non-top snap shot of VM disk can not be deleted
Status: CLOSED DUPLICATE of bug 833752
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Kenigsberg
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 03:02 EDT by shu ming
Modified: 2014-01-12 19:53 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 03:25:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shu ming 2012-07-16 03:02:06 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a VM in oVirt engine 3.1 with a disk
2.Create snap shot 1 for the VM
3.Create snap shot 2 for the VM
4. Delete the snap shot 1 in the VM
  
Actual results:
snap shot 1 can not be deleted and the status of the snap shot will be marked as in "BROKEN" state

Expected results:
snap shot 1 was deleted

Additional info:
Errors in vdsm.log

4ce5e915-5968-4290-8d6c-72d15cec010a::ERROR::2012-07-16 15:15:00,317::task::853::TaskManager.Task::(_setError) Task=`4ce5e915-5968-4290-8d6c-72d15cec010a`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 861, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 320, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 63, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1786, in mergeSnapshots
    image.Image(repoPath).merge(sdUUID, vmUUID, imgUUID, ancestor, successor, postZero)
  File "/usr/share/vdsm/storage/image.py", line 1146, in merge
    raise se.SourceImageActionError(imgUUID, sdUUID, str(e))
SourceImageActionError: Error during source image manipulation: "image=d7374434-239d-4ae2-a4d6-0eb7986b4e8c, source domain=406a7682-6fde-4cde-bf4e-b4310dd2c294: _log() got an unexpected keyword argument 'volUUID'"
Comment 1 shu ming 2012-07-16 03:25:08 EDT

*** This bug has been marked as a duplicate of bug 833752 ***

Note You need to log in before you can comment on or make changes to this bug.