Bug 840380 - dracut can't find the network module even though it's installed
dracut can't find the network module even though it's installed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 04:01 EDT by Sandro Mathys
Modified: 2012-07-16 05:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 05:28:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dracut --M --force --verbose --debug 2> dracut.err (3.93 MB, application/octet-stream)
2012-07-16 04:01 EDT, Sandro Mathys
no flags Details

  None (edit)
Description Sandro Mathys 2012-07-16 04:01:57 EDT
Created attachment 598389 [details]
dracut --M --force --verbose --debug 2> dracut.err

Description of problem:
dracut reports 'Dracut module "network" cannot be found.' even though it is installed.

Version-Release number of selected component (if applicable):
dracut-018-78.git20120622.fc17.noarch
dracut-network-018-78.git20120622.fc17.noarch

How reproducible:
Always.

Steps to Reproduce:
1. yum install -y dracut{,-network}
2. dracut --force -M
  
Actual results:
'Dracut module "network" cannot be found.' x4

Expected results:
New initramfs is built with the network module included

Additional info:
dracut.conf and 01-dist.conf are untouched. Our additional custom conf looks like this (note: we only really need nfsroot support from network module and there's no local disks in this setup whatsoever):
# Dracut modules to omit
omit_dracutmodules+="btrfs crypt dm dmraid dmsquash-live fcoe ifcfg iscsi lvm mdraid nbd"

# install local /etc/mdadm.conf
mdadmconf="no"

# install local /etc/lvm/lvm.conf
lvmconf="no"
Comment 1 Harald Hoyer 2012-07-16 05:28:40 EDT
//etc/dracut.conf.d/10-ethz.conf@2(): omit_dracutmodules+='btrfs crypt dm dmraid dmsquash-live fcoe ifcfg iscsi lvm mdraid nbd'

The network module depends on the ifcfg module and you have forced dracut to omit this module.

I agree, that the error message could state that and will fix it.

Note You need to log in before you can comment on or make changes to this bug.