Bug 840388 - webadmin: the create new snapshot dialogue will not close until create task is created and send to vdsm by backend which is highly visible when vm has several disks
webadmin: the create new snapshot dialogue will not close until create task i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Alexey Chub
Dafna Ron
virt, infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 04:41 EDT by Dafna Ron
Modified: 2013-03-20 02:19 EDT (History)
9 users (show)

See Also:
Fixed In Version: si15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:05:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-07-16 04:41:39 EDT
Description of problem:

when we create a snapshot, the create snpashot dialogue does not close until each disk snapshot is sent to vdsm. 
if we have a vm with several disks the dialogue remains open until we send each disk's task to vdsm
this is highly visible and gives impression that there is something wrong. 

Version-Release number of selected component (if applicable):

si10

How reproducible:

100%

Steps to Reproduce:
1. create a vm with 6-7 disks and create a snapshot
2.
3.
  
Actual results:

create disks dialogue will not be closed until tasks have been created and sent to vdsm by backend. 

Expected results:

we should close dialogue and fail with CanDoAction if needed. 

Additional info:
Comment 1 Simon Grinberg 2012-07-16 05:16:44 EDT
(In reply to comment #0)
> Expected results:
> 
> we should close dialogue and fail with CanDoAction if needed. 
> 
> Additional info:

The implication of that means that a user will not get notified that the initiation of the clone has failed, it will only be visible in the event log.

It will also require two level of async task management, one GUI to BE, and then BE to VDSM. Currently as I recall there is only the later. 

Not sure this is the right solution. Indeed if the snapshot creation itself fails on VDSM, then again it will only show in the even log, but this is unavoidable since the actual snapshot creation is far longer then just sending the task (especially when live snapshot are involved).

The solution may be either a better indication that the task is still being created or sending those tasks concurrently to VDSM and not sequentially.
Comment 3 Einav Cohen 2012-07-26 08:01:47 EDT
assuming most of the delay is in the "Execute" part of the command rather than the "CanDoAction" part, the call to RunAction can change to RunMultipleAction (so the "Execute" part will run asynchronously, hence the GUI "delay" will be shorter)
Comment 4 Alexey Chub 2012-08-05 07:27:18 EDT
Change-Id: I12a0b708e61d21b2a6276620d7350e626eb12fd8
Comment 5 Dafna Ron 2012-08-12 11:54:13 EDT
checked on si13.2
the dialogue is still not closing until all CreateSnapshotVDSCommand for each of the disks is run. 
moving back to devel.
Comment 6 Einav Cohen 2012-08-16 08:40:14 EDT
indeed - seems that patch hasn't been cherry-picked downstream.
Comment 7 Alexey Chub 2012-08-19 03:39:24 EDT
Change-Id: I12a0b708e61d21b2a6276620d7350e626eb12fd8
Comment 8 Dafna Ron 2012-08-23 08:44:16 EDT
verified on si15

Note You need to log in before you can comment on or make changes to this bug.