Bug 840408 - Does not connect to IRC if nick already in use
Does not connect to IRC if nick already in use
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: empathy (Show other bugs)
7.0
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 05:40 EDT by Tomas Jamrisko
Modified: 2014-04-22 08:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-22 08:56:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 680024 None None None 2012-07-16 11:16:09 EDT
FreeDesktop.org 14751 None None None 2012-10-29 12:36:48 EDT

  None (edit)
Description Tomas Jamrisko 2012-07-16 05:40:48 EDT
Description of problem:

Empathy does not connect to irc if nick is already in use, which is understandable and not a bug per se.

The problem lies in empathys unability to reconnect to IRC server after unexpected loss of connection (e.g. unplugged cable). It is fairly reasonable to assume that connection should be restored asap, albeit at the expense of changing nick (adding underscore, number, whatever -- as most other clients do)  

Version-Release number of selected component (if applicable):
empathy-3.4.2.1-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Connect to IRC server
2. Disable your networking
3. Enable networking
Comment 4 Debarshi Ray 2013-11-01 10:45:43 EDT
You are not supposed to use empathy for IRC in RHEL7, which is why we do not ship telepathy-idle. Please use xchat instead.

Note You need to log in before you can comment on or make changes to this bug.