Bug 840435 - [RHEVM] [backend] Cannot assign static IP for VLAN interface with DC/CL3.0
[RHEVM] [backend] Cannot assign static IP for VLAN interface with DC/CL3.0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:34 EDT by Martin Pavlik
Modified: 2016-02-10 14:50 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 10:08:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Pavlik 2012-07-16 07:34:41 EDT
Description of problem:
Cannot assign static IP for VLAN interface with DC/CL3.0

Version-Release number of selected component (if applicable):
oVirt Engine Version: '3.1.0-6.el6ev' 
vdsm-4.9-113.1.el6.x86_64 (rhev-h 6.3)

How reproducible:
always

Steps to Reproduce:
1. create logical network with VLAN tag and assign it to cluster
2. add new network to host NIC (Boot Protocol = None)
3. edit the interface again (Boot Protocol = Static) -> fill in IP and mask -> click OK
  
Actual results:
Edit Network interface dialog just reappears, with no error in GUI

Expected results:
Static IP should be set properly

Additional info:
Only following message appears in engine.log:

2012-07-16 13:28:13,137 WARN  [org.ovirt.engine.core.bll.UpdateNetworkToVdsInterfaceCommand] (ajp-/0.0.0.0:8009-10) [5ccfc51b] CanDoAction of action UpdateNetworkToVdsInterface failed. Reasons:NETWROK_OLD_NETWORK_NOT_SPECIFIED
Comment 1 Martin Pavlik 2012-07-16 10:08:06 EDT
Host was not in maintanace mode, due to problem with firefox, warning that host needs to be switched was not displayed.

Note You need to log in before you can comment on or make changes to this bug.