Bug 840439 - Unable to assign a repository to multiple CDS clusters
Unable to assign a repository to multiple CDS clusters
Status: CLOSED NOTABUG
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 07:45 EDT by mkovacik
Modified: 2012-07-16 09:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 09:55:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen log (10.49 KB, application/octet-stream)
2012-07-16 07:45 EDT, mkovacik
no flags Details
Verifying screen log (6.77 KB, text/plain)
2012-07-16 09:41 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-07-16 07:45:47 EDT
Created attachment 598432 [details]
Screen log

Description of problem:
No repository is offered to assign to a newly created CDS cluster even both a Red Hat and a custom repository are registered with the RHUI instance

Version-Release number of selected component (if applicable):


How reproducible:
1of1


Steps to Reproduce:
1. create CDS cluster A
2. add a Red Hat repository Rh
3. add a custom repository Rc
4. create a CDS cluster B (by "moving" one node from a multi-node cluster A)
5. try to assign a repository to the cluster B
6. no repository is available for assignment

Actual results:
One is unable to associate a repository to multiple clusters

Expected results:
It is possible to associate a repository to multiple clusters


Additional info:
- see as well the attached screen log
- might be related to bug 840005
Comment 1 mkovacik 2012-07-16 09:41:46 EDT
Created attachment 598452 [details]
Verifying screen log

Actually, this isn't a bug: creating a new repository assigns it to all the available clusters, hence a repository can indeed be assigned to multiple clusters.
Comment 2 mkovacik 2012-07-16 09:55:06 EDT
well, not to all of them, but to the first cluster created. However, it then can be assigned to any other clusters; closing as not a bug...

Note You need to log in before you can comment on or make changes to this bug.