Bug 840478 - As a Sysadmin of SAM I would like to have documentation for Backing up and Recovering a SAM installation.
As a Sysadmin of SAM I would like to have documentation for Backing up and Re...
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
1.2
Unspecified Unspecified
urgent Severity urgent
: rc
: 1.2
Assigned To: sachua
ecs-bugs
: Documentation
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-07-16 09:12 EDT by Eric Sammons
Modified: 2013-03-11 19:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-11 19:35:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Backup Procedure for System Engine (5.68 KB, text/xml)
2012-09-11 10:59 EDT, Dan Macpherson
no flags Details
Restore Procedure for System Engine (4.67 KB, text/xml)
2012-09-11 11:00 EDT, Dan Macpherson
no flags Details

  None (edit)
Description Eric Sammons 2012-07-16 09:12:18 EDT
Description of problem:
As a sysadmin of SAM I would like documentation for backing up and recovering a SAM installation.  Including all candlepin (manifest), system, org, etc.. data.

Documentation should clearly outline the steps and commands to use.
Comment 1 sachua 2012-09-05 01:00:48 EDT
Hi Bryan, can you please assist with the steps for backing up and recovery? Thanks.
Comment 2 Dan Macpherson 2012-09-11 10:58:53 EDT
Hi Sarah,

BK and I spoke about this bug. Turns out it'll be pretty easy for you. For a start, the SAM Backup and Restore procedures are essentially the same as the Katello Backup and Restore procedures:

https://fedorahosted.org/katello/wiki/GuideServerBackups

The only difference is the SAM Backup and Restore procedures do not contain pulp and mongo backups or restores.

Now to make this even easier for you, I've already written a Docbook version for System Engine. I'll attach these two procedures to this bug.

All you need to do is remove the pulp and mongo references, and then replace mentions of System Engine for SAM.
Comment 3 Dan Macpherson 2012-09-11 10:59:33 EDT
Created attachment 611806 [details]
Backup Procedure for System Engine
Comment 4 Dan Macpherson 2012-09-11 11:00:05 EDT
Created attachment 611808 [details]
Restore Procedure for System Engine

Note You need to log in before you can comment on or make changes to this bug.