Bug 840492 - "shutdown -n now" with wrong option makes host/guest into single user mode
"shutdown -n now" with wrong option makes host/guest into single user mode
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: upstart (Show other bugs)
6.4
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 09:48 EDT by Xiaomei Gao
Modified: 2015-10-13 08:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 08:55:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shutdown patch (524 bytes, patch)
2012-07-17 06:31 EDT, Lukáš Nykrýn
no flags Details | Diff

  None (edit)
Description Xiaomei Gao 2012-07-16 09:48:00 EDT
Description of problem:

'shutdown -a/-f/-g/-n/-q/-v now' with these options all make guest into 

single user mode, but "man shutdown" has no these options.  


Version-Release number of selected component (if applicable):

#rpm -qf `which shutdown`

upstart-0.6.5-12.el6.x86_64

How reproducible:

100%

Steps to Reproduce:

1. # shutdown -n now
   
   The system is going down for maintenance NOW!

2. # runlevel 
     1 S

3. man shutdown
  
Actual results:

host/huest goes into single mode

Expected results:

should prompt info: shutdown: invalid option -- 'n'

Additional info:
Comment 2 Lukáš Nykrýn 2012-07-17 06:31:58 EDT
Created attachment 598599 [details]
shutdown patch

Thanks for the report, there should be probably some check for args. I will discuss this with upstream.
Comment 3 Lukáš Nykrýn 2012-07-24 07:37:32 EDT
This behavior is actually the same as in sysvinit. Maybe it would be better just to mention it in manpage. Again I will discuss this with upstream.
Comment 4 RHEL Product and Program Management 2012-09-07 01:10:51 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Lukáš Nykrýn 2015-10-13 08:55:04 EDT
This behavior is because of backward compatibility.

Note You need to log in before you can comment on or make changes to this bug.