Bug 840495 - webadmin: we do not clean alerts from the webadmin once fixed
webadmin: we do not clean alerts from the webadmin once fixed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Eli Mesika
Dafna Ron
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 09:51 EDT by Dafna Ron
Modified: 2016-02-10 14:20 EST (History)
11 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dafna Ron 2012-07-16 09:51:08 EDT
Description of problem:

we map certain auditlogs as alert and present them in the alerts tab (such as power management). 
if I fixed the issue (configured the power management on the host) we should clean the alert from the UI even if they are kept in the db for reports. 

Version-Release number of selected component (if applicable):

si10

How reproducible:

100%

Steps to Reproduce:
1. add a host without power management
2. configure power management 
3. look at the ALERTS tab in the webadmin
  
Actual results:

alerts are not removed from the log 

Expected results:

alerts should be removed once fixed

Additional info:
Comment 2 Einav Cohen 2012-07-26 07:50:02 EDT
could be:

1. backend is not cleaning the alerts once handled (backend problem), or:

2. backend cleans the alerts appropriately, but GUI isn't refreshed (GUI problem)
Comment 3 Eli Mesika 2012-08-01 16:38:47 EDT
Can not reproduce with the given scenario.
Alerts are removed correctly from the DB & from the UI Alert TAB.

Please redo the scenario and before pressing the OK when setting PM , click the TEST button. If TEST is not succeeded , the Alert will not be removed.

Meaning : problem fixed = (PM configured) & (TEXT succeeded)
Only when those 2 conditions are met , the Alert is removed.
Comment 4 Dafna Ron 2012-08-02 03:23:24 EDT
(In reply to comment #3)
> Can not reproduce with the given scenario.
> Alerts are removed correctly from the DB & from the UI Alert TAB.
> 
> Please redo the scenario and before pressing the OK when setting PM , click
> the TEST button. If TEST is not succeeded , the Alert will not be removed.
> 
> Meaning : problem fixed = (PM configured) & (TEXT succeeded)
> Only when those 2 conditions are met , the Alert is removed.

I do not see a reason why only when we press the test button the alert should be removed. 
the alert says "no power management configured" it does not say "power management was not tested"
Comment 5 Eli Mesika 2012-08-02 05:04:09 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Can not reproduce with the given scenario.
> > Alerts are removed correctly from the DB & from the UI Alert TAB.
> > 
> > Please redo the scenario and before pressing the OK when setting PM , click
> > the TEST button. If TEST is not succeeded , the Alert will not be removed.
> > 
> > Meaning : problem fixed = (PM configured) & (TEXT succeeded)
> > Only when those 2 conditions are met , the Alert is removed.
> 
> I do not see a reason why only when we press the test button the alert
> should be removed. 
> the alert says "no power management configured" it does not say "power
> management was not tested"

I see no reason to remove an Alert just because someone inserted wrong data in the PM field.
Configured means configured correctly and certainly working.
When you press the OK, if you not press TEST, the test is called implicitly.

I would see it as a BUG if you mistake in the PM parameters and the Alert is removed and you will only know it when your host is Non-Responding and we fail to restrart the host because the PM is not correct.

This is working as desined and should stay as is.
Comment 6 Dafna Ron 2012-08-02 05:36:54 EDT
1. someone did not insert a wrong data, he configured the power management without testing the data. just because he did not press the test button does not mean that the data is wrong
2. configure does not mean configure correctly. if a user did not press the test button we can say that we cannot verify the power management but we cannot say that it is not configured. 
3. if something happened to the power management after the test button was pressed or the power management parameters were changed at the HW level - would we bring back the power management not configured alert? the answer is no. 
granted there is an RFE to daily check the validity of the power management :) 
but it is configured - just not validated. 

I am adding Simon to this bug and opening a keep alive RFE for power management.
Comment 7 Einav Cohen 2012-08-02 07:22:34 EDT
moving component to backend (since the issue here is when alerts should be cleared from DB, not related to GUI).
Comment 10 Simon Grinberg 2012-08-02 08:14:31 EDT
The test now - is for the user to check is parameters without having to close the dialog .

When pressing OK, we should auto test and clear the entry. If test fails then please write the alert as before, but change it to failed to verify power management configuration.  


In addition we do need keep alive as suggested by Dafna, otherwise at D-day recovery may fail.
Comment 11 Eli Mesika 2012-08-04 16:08:54 EDT
http://gerrit.ovirt.org/#/c/6880/
Comment 12 Eli Mesika 2012-08-09 19:44:14 EDT
fixed in commit: 625dd57
Comment 14 Dafna Ron 2012-09-02 04:41:36 EDT
verified on si16

Note You need to log in before you can comment on or make changes to this bug.