Bug 840532 - Generating client-side entitlements fails
Generating client-side entitlements fails
Status: CLOSED DUPLICATE of bug 838583
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Slagle
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 10:47 EDT by mkovacik
Modified: 2012-07-16 11:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 11:45:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen log (20.09 KB, text/plain)
2012-07-16 10:47 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2012-07-16 10:47:08 EDT
Created attachment 598466 [details]
Screen log

Description of problem:
Generating client-side entitlements fails with an unexpected error. .rhui/rhui.log shows a stack dump:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhui/tools/shell.py", line 86, in safe_listen
    self.listen(clear=first_run)
  File "/usr/lib/python2.6/site-packages/rhui/tools/shell.py", line 112, in listen
    Shell.listen(self)
  File "/usr/lib/python2.6/site-packages/rhui/common/shell.py", line 186, in listen
    item.func(*args, **item.kwargs)
  File "/usr/lib/python2.6/site-packages/rhui/tools/screens/client.py", line 88, in generate
    if repo['repo_id'] not in cluster['repo_ids']:
KeyError: 'repo_id'


Version-Release number of selected component (if applicable):
RHEL-6.3-RHUI-2.1-20120705.0-Server-x86_64-DVD1.iso

How reproducible:
1of1

Steps to Reproduce:
1. create CDS cluster
2. add and sync RHEL contents to the cluster 
3. create custom protected repository and upload contents
4. generate entitlement for client
5. stack dupmed

  
Actual results:
Unable to generate client entitlement

Expected results:
Client entitlement generated

Additional info:
see the attached screen log
Comment 1 wes hayutin 2012-07-16 11:45:57 EDT

*** This bug has been marked as a duplicate of bug 838583 ***

Note You need to log in before you can comment on or make changes to this bug.