Bug 840536 - one network interface on Emulex OCE11102 fails to establish logical link with Cisco N7k switch
one network interface on Emulex OCE11102 fails to establish logical link with...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
6.0
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Andy Grover
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 10:48 EDT by feiwang
Modified: 2012-09-01 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-01 22:38:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description feiwang 2012-07-16 10:48:09 EDT
Description of problem:

one network interface on Emulex OCE11102 fails to establish logical link with Cisco N7k switch while the other network interface is ok, please notice that link is already up as per "ethtool ethx" command and the mac address can be seen in the target port on the switch, but ping doesn't work as expected

Version-Release number of selected component (if applicable):

[root@ARCX3650YNAGX ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.0 (Santiago)
[root@ARCX3650YNAGX ~]# uname -r
2.6.32-71.el6.x86_64

Cisco N7K Switch

Software
  BIOS:      version 3.22.0
  kickstart: version 5.2(3a)
  system:    version 5.2(3a)
  BIOS compile time:       02/20/10
  kickstart image file is: bootflash:///n7000-s1-kickstart.5.2.3a.bin
  kickstart compile time:  12/25/2020 12:00:00 [12/15/2011 20:04:59]
  system image file is:    bootflash:///n7000-s1-dk9.5.2.3a.bin
  system compile time:     12/15/2011 12:00:00 [12/15/2011 21:15:48]


How reproducible:

Always

Steps to Reproduce:
1.eth2 and eth3 are the two network interfaces of Emulex OCE11102 in this system
2.the IP address of eth2 and eth3 are set as xxx.xxx.100.54 and xxx.xxx.100.55 respectively
3.run "ping xxx.xxx.100.1 -I ethx" command to test the connectivity where xxx.xxx.100.1 is on the same subnet of eth2 and eth3
  
Actual results:

it is ok for eth2 while eth3 consistently fails 

Expected results:

both eth2 and eth3 should ping xxx.xxx.100.1 successfully

Additional info:

1."ethtool eth3" shows link is up
2.changed the IP address of eth3 to another IP address, i.e xxx.xxx.100.132 to rule out IP address conflict, still fails
3.update the be2net driver from the inbox one to the latest one 4.1.402.6, still fail
4.run no shutdown and shutdown command on Cisco N7K switch to restart the target port on Cisco N7K still not work, and the target ports settings are the exactly the same
Comment 2 feiwang 2012-07-16 23:00:36 EDT
changed component from NetworkManager to iscsi-initiator-utils to better reflect this issue, although this seems to be a compatibility issue, thanks.
Comment 3 feiwang 2012-07-16 23:03:53 EDT
addtional information about this Emulex OCE11102 CNA card:
this card only has NIC function and has no iSCSI HW or FCoE functionality, and the firmware is 4.0.1062.0 and driver is 4.0.1054.0, i have also tried 4.1.402.6 driver version, but no help.
Comment 4 feiwang 2012-09-01 22:38:44 EDT
Change the status to closed, for your information, the solution is to modify the value of "net.ipv4.conf.default.rp_filter" in /etc/sysctl.conf from the default 1 to 0, and it prompts you to change this value when you run iscsiadm -m discovery -t sendtargets -p target IP:3260. Thanks for your time.

Note You need to log in before you can comment on or make changes to this bug.