Bug 840547 - attempt to copy large directory hierarchy to smart phone over MTP with gvfs-gphoto2 results in OOM
attempt to copy large directory hierarchy to smart phone over MTP with gvfs-g...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Holy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 10:55 EDT by Jonathan Kamens
Modified: 2013-06-25 10:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-25 10:02:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2012-07-16 10:55:53 EDT
Configured my new Galaxy S III in MTP mode. Plugged it in, and opened its Music folder in Nautilus. Attempted to drag and drop >13GB of music files into the folder from the folder on my PC where I keep my music. It copied for a while, then I ran out of RAM and the kernel's OOM killer killed it.

I have 16GB of RAM, of which it is rather for more than 4GB is in use.

When the kernel killed gvfsd-gphoto2, it was using 9GB of RAM:

Jul 16 09:45:38 jik2 kernel: [ 1299.845706] Killed process 3486 (gvfsd-gphoto2) total-vm:9150908kB, anon-rss:8410080kB, file-rss:8kB

Methinks either it has a significant memory leak or it needs to be better about cleaning up no-longer-needed memory as it works rather than waiting until the end of a huge operation.
Comment 1 Fedora Admin XMLRPC Client 2013-05-23 10:27:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2013-05-23 10:29:14 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Dan 2013-06-05 14:36:49 EDT
Hello, I also have the same bug and am keen to get this issue resolved. Please let me know how I can help.
Comment 4 Tomáš Bžatek 2013-06-25 10:02:50 EDT
Newer gvfs versions introduced new MTP backend that is more suitable for such devices. However since it's dependent on libmtp, we have no plans for backporting it to older Fedora releases. Suggesting to use Fedora 19 which is going to be released next week hopefully. There are some extra quirks specially for Android-based devices.

Note You need to log in before you can comment on or make changes to this bug.