Bug 840558 - [rhevm] [web-admin] Creating a V1 block data storage domain should be allowed in order to reinitialize a 3.0 DC with V1 block domains
[rhevm] [web-admin] Creating a V1 block data storage domain should be allowed...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity low
: ---
: 3.1.0
Assigned To: Daniel Erez
vvyazmin@redhat.com
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 11:17 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 11:53 EST (History)
9 users (show)

See Also:
Fixed In Version: si16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs vdsm, rhevm, screen-shots (894.64 KB, application/x-gzip)
2012-07-16 11:18 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-07-16 11:17:45 EDT
Description of problem:
WebAdmin allow create new iSCSI Storage Domain, with format V1, that not attached to Data Center (Data Center == (none))

Version-Release number of selected component (if applicable):
RHEVM 3.1 - SI10

RHEV-M: rhevm-3.1.0-6.el6ev.noarch
VDSM: vdsm-4.9.6-21.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.1.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a new iSCSI Storage Domain, with format V1, that not attached to Data Center (Data Center == (none)) – print-screen attached

  
Actual results:
WebAdmin allow create new iSCSI Storage Domain, with format V1

Expected results:
Option select  new iSCSI Storage Domain, with format V1 must be removed. 

Additional info:
Comment 1 vvyazmin@redhat.com 2012-07-16 11:18:40 EDT
Created attachment 598481 [details]
## Logs vdsm, rhevm, screen-shots
Comment 2 Haim 2012-07-16 12:52:00 EDT
There is no point of allowing creation on V1 storage domain, it just leaves a door to nasty bugs in the upgrade process, rhevm 3.1 only supports 3.0 and 3.1 compatibility version, which means either v2 or v3 (in the coming build).
please filter it out from the GUI.
Comment 3 Itamar Heim 2012-07-16 19:06:11 EDT
other than export/iso domains?
Comment 4 Haim 2012-07-17 03:29:20 EDT
(In reply to comment #3)
> other than export/iso domains?

correct.
Comment 6 Daniel Erez 2012-07-26 02:09:07 EDT
http://gerrit.ovirt.org/#/c/6629/1
Comment 7 Yaniv Kaul 2012-07-26 06:45:14 EDT
I assume they cannot be created from the API as well?
Comment 8 Ayal Baron 2012-07-31 16:18:02 EDT
(In reply to comment #7)
> I assume they cannot be created from the API as well?

Moving back to post seeing as current patch does not prevent it in API only in GUI.
Comment 9 Itamar Heim 2012-08-07 20:25:26 EDT
maybe should keep the api for now.
3.0 DC doesn't mean its not V1, and you need 'none' to reconstruct?
(although, if there is more than a single storage domain, you don't need to add with none, and if it was a single storage domain, maybe we want to reconstruct on V2 (though we probably block from adding a V2 storage domain to a V1 DC)
Comment 10 Ayal Baron 2012-08-08 11:01:08 EDT
Users can upgrade from 3.0 with a DC containing only V1 storage domains.  In such a scenario we must allow reinitializing the DC with a V1 storage domain, hence this is not a bug.
Comment 11 Ayal Baron 2012-08-08 11:03:22 EDT
need to revert the patch that was committed.
Comment 12 Daniel Erez 2012-08-22 04:19:35 EDT
patch sent upstream:
http://gerrit.ovirt.org/#/c/7388/
Comment 15 Allon Mureinik 2012-08-26 07:43:49 EDT
Change-Id: Ib0dd0dd838b3a56b50fa7f9f93925a5002793e07 merged
Comment 16 vvyazmin@redhat.com 2012-09-03 09:06:02 EDT
Succeeded create iSCSI Storage Domain, with format V1 that not attached to Data Center (Data Center == (none))
Failed attached to iSCSI Storage Domain v3.0 and v3.1 
Warning message displayed on Admin UI


Verified on RHEVM 3.1 - SI16

RHEVM: rhevm-3.1.0-14.el6ev.noarch
VDSM: vdsm-4.9.6-31.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.4.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.1.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64

Note You need to log in before you can comment on or make changes to this bug.