This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 840587 - [doc] Upgrade procedure section should mention ipa-ldap-updater
[doc] Upgrade procedure section should mention ipa-ldap-updater
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Identity_Management_Guide (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tomas Capek
Namita Soman
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 11:54 EDT by Dmitri Pal
Modified: 2014-10-20 08:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-20 08:30:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-07-16 11:54:23 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/2918

Section ''2.6.1. Upgrading Packages'' states:
{{{
The update process automatically updates all schema and LDAP configuration,
Apache configuration, and other services configuration, and restarts all 
FreeIPA-associated services.
}}}

I think we should expand this information and add a note about ipa-ldap-updater:

{{{
Schema and LDAP configuration updates are done with /usr/sbin/ipa-ldap-updater
program. Unexpected LDAP upgrade failures may cause issues when using IPA. 
Thus, IPA LDAP upgrade log (/var/log/ipaupgrade-log) may be consulted for
errors happened during package upgrade.

When the cause of the failure is fixed, the IPA LDAP updater may be 
manually executed again:

# /usr/sbin/ipa-ldap-updater --upgrade
}}}
Comment 3 Namita Soman 2014-09-25 13:53:46 EDT
Verified the new note - 

The LDAP upgrade operation is logged in the upgrade log at /var/log/ipaupgrade-log. If any LDAP errors occur, then they are recorded in that log. Once any errors are resolved, the LDAP update process can be manually initiated by running the updater script:

[root@server ~]# ipa-ldap-updater --upgrade

Note You need to log in before you can comment on or make changes to this bug.