Bug 840630 - Need to add "Callback5Queue" to the schema scripts/hornetq extras script
Need to add "Callback5Queue" to the schema scripts/hornetq extras script
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise SOA Platform 5
Classification: JBoss
Component: Integration (Show other bugs)
5.3.0 GA
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 5.3.0 GA
Assigned To: Douglas Palmer
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 14:07 EDT by tcunning
Modified: 2014-10-15 13:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-15 13:26:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files that need to be added to soa-jbpm5/repository/JBossESB (4.85 KB, application/x-gzip)
2012-07-18 23:59 EDT, tcunning
no flags Details
New ESBAction.html (1.07 KB, text/html)
2012-07-19 13:14 EDT, tcunning
no flags Details
New JBossESB.wid.template (3.76 KB, application/x-iwork-pages-sfftemplate)
2012-07-19 13:14 EDT, tcunning
no flags Details

  None (edit)
Description tcunning 2012-07-16 14:07:50 EDT
Description of problem:

As part of the solution to https://bugzilla.redhat.com/show_bug.cgi?id=839327, an ESB-aware queue needs to be added for the CallbackService.     The queue is going to be named "Callback5Service", and needs to be added to the extras/hornetq script.
Comment 1 tcunning 2012-07-18 23:57:57 EDT
The Callback5Queue is now not necessary and has been removed, due to changes we've made because of transactions.     The queue will be stored in the developer's ESB archive.     I know that we added it to the hornetq script, but can it now be removed?

Attaching a tar.gz which contains new files that need to be added to soa-jbpm5/repository/JBossESB.     There are a few new files here that need to be added (ESBAction.conf, ESBAction.html), JBossESB.wid.template has changed.   I think the rest of the files are the same.
Comment 2 tcunning 2012-07-18 23:59:07 EDT
Created attachment 599052 [details]
Files that need to be added to soa-jbpm5/repository/JBossESB
Comment 3 Douglas Palmer 2012-07-19 05:02:25 EDT
svn ci -m"[BZ840630] Added ESBAction to jbpm5 config" soa-p/src/main/resources/soa-p/jbpm5/repository/JBossESB
Adding         soa-p/src/main/resources/soa-p/jbpm5/repository/JBossESB/ESBAction.conf
Adding         soa-p/src/main/resources/soa-p/jbpm5/repository/JBossESB/ESBAction.html
Sending        soa-p/src/main/resources/soa-p/jbpm5/repository/JBossESB/JBossESB.wid.template
Transmitting file data ...
Committed revision 11287.
Comment 4 tcunning 2012-07-19 13:14:20 EDT
Created attachment 599206 [details]
New ESBAction.html
Comment 5 tcunning 2012-07-19 13:14:54 EDT
Created attachment 599207 [details]
New JBossESB.wid.template
Comment 6 tcunning 2012-07-19 13:16:15 EDT
Need to add these new versions of ESBAction.html and JBossESB.wid.template.
Comment 7 Ryan Zhang 2012-07-20 02:35:05 EDT
Please verify this issue on 5.3.0 CR1.
Comment 8 Marek Baluch 2012-07-25 03:47:02 EDT
Verified on CR1. 

Queue has been removed from the hornetq install script because it was not needed anymore.

Note You need to log in before you can comment on or make changes to this bug.