Bug 84067 - rhn-applet-gui segfault immediately
rhn-applet-gui segfault immediately
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: rhn-applet (Show other bugs)
phoebe
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks: 79578
  Show dependency treegraph
 
Reported: 2003-02-11 15:15 EST by Harris Landgarten
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-13 09:23:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of rhn-applet-gui with segfault (480.22 KB, text/plain)
2003-02-12 07:29 EST, Harris Landgarten
no flags Details

  None (edit)
Description Harris Landgarten 2003-02-11 15:15:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
rhn-applet-gui is seqfaulting somewhere early in rhn-applet.py

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rhn-applet-gui
2.
3.
    

Actual Results:  Segmentation fault

Expected Results:  applet in notification area

Additional info:

up2date runs fine.
Comment 1 Harris Landgarten 2003-02-11 15:17:44 EST
I tried updating to :

rhn-applet-2.0.8-1
rhnlib-1.0-3

from rawhide with same results
Comment 2 Michael Young 2003-02-12 05:46:22 EST
Is /usr/lib/python2.2/site-packages/bonobo empty? If not, this could be bug
79652 again (graphical up2date would also fail in this case, but text mode
up2date could work).
Comment 3 Harris Landgarten 2003-02-12 07:29:01 EST
Created attachment 90031 [details]
strace of rhn-applet-gui with segfault

strace of rhn-applet-gui with segfault
Comment 4 Harris Landgarten 2003-02-12 07:32:25 EST
[harrisl@d8100 harrisl]$ ls /usr/lib/python2.2/site-packages/bonobo
activationmodule.so  _bonobomodule.so  __init__.py  __init__.pyc  __init__.pyo 
uimodule.so

Graphical up2date works perfectly. I uploaded an strace.
Comment 5 Michael Young 2003-02-12 11:03:06 EST
Even so it is still probably bug 79652 , as that directory should be empty. Read
the instructions in that bug or upgrade gnome-python2-bonobo to 1.99.14-5 or later.
Comment 6 Harris Landgarten 2003-02-12 20:43:33 EST
I removed all files from /usr/lib/python2.2/site-packages/bonobo and upgraded to
gnome-python2-bonobo-1.99.14-5 but am still getting the same segfault. 

When I upgraded to phoebe, Anaconda messed up and ignored the /usr is fstab,
created a new /usr on / and wrote all content meant for /usr in the wrong place.
Inorder to rescue the installation, I had to copy the wrong /usr on top of the
old /usr so everything that wasn't overwritten is still there. Are there other
left over files that could be causing this problem? There are certainly other
files that are not part of RPMs but I don't want to do a wholesale rm -rf on
everything rpm doesn't lay claim to. Are there specific directories that should
not have any unpackaged files?
Comment 7 Michael Young 2003-02-13 04:54:56 EST
This is getting way beyond my area of expertise, but if you have anything in
/usr/lib/python2.2/site-packages/gtk (empty on my machine) that isn't claimed by
a package (rpm -qf filename) try removing it or renaming it - I am guessing the
stuff that was in that directory in 8.0 has been moved to .../gtk-2.0/gtk in phoebe.
Comment 8 Daniel Veillard 2003-02-13 05:44:21 EST
Hum, considering that 1/ you're the only one reporting the problem,
2/ the /usr copy do mess with timestamps 3/ that as a result you may have
python compiled object more recent than their source counterparts

then the fact that you may have serious troubles is not that surprizing,
I highly suggest you restart a clean installation and report if you
still see the problem. Obviously the state of your system is nearly
impossible to reproduce, it is not the normal state generated by a
normal install or upgrade path, and I think it's nearly impossible to 
fix just by getting symptoms reports,

Daniel
Comment 9 Harris Landgarten 2003-02-13 09:14:22 EST
I removed all non owned packages from /usr/lib/python2.2 and that resolved the
problem.  rhn-applet-gui is running normally now. Thanks for the help.  BTW the
/usr problem was submitted by me as 83816. As far as I know it has not been
resolved and given the problems you have pointed out, if not fixed it can really
hose an upgrade and kill alot of time.
Comment 10 Daniel Veillard 2003-02-13 09:23:02 EST
Okay 83816 has a life of its own, we don't need to keep this bug open
since apparently it was solved by trying to fix the correction measure
taken against 83816. I think we can resonnably close this bug as not
being a rhn-applet bug at this point,

  thanks for the quick feedback,

Daniel

Note You need to log in before you can comment on or make changes to this bug.