Bug 840681 - Prepare JRuby package in anticipation of 1.7.0 release
Prepare JRuby package in anticipation of 1.7.0 release
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: jruby (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bohuslav "Slavek" Kabrda
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 17:56 EDT by Dan Allen
Modified: 2014-07-24 23:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-13 03:01:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Allen 2012-07-16 17:56:41 EDT
Prepare JRuby package for Fedora 18 in anticipation of 1.7.0 release.

Motivation:

JRuby 1.7.0 offers compatibility with Ruby 1.9.3. Ruby 1.9 is the default run mode in JRuby 1.7.0 (with -1.8 required for 1.8.x support). When running on Java 7, JRuby 1.7.0 offers significant performance gains by leveraging invokedynamic (JVM new support for dynamic languages). Users of highly-concurrent applications will see improvements in throughput and raw parallelism.

Since JRuby 1.7.0 changes the default run mode to Ruby 1.9, it's reasonable for this package to target Fedora 18 rather than Fedora 17. If there is support for making it available in Fedora 17, we could consider swapping the default run mode in the JRuby 1.7.0 package so that it behaves consistently with the JRuby 1.6.x line (existing package).
Comment 1 Vít Ondruch 2012-07-17 02:56:52 EDT
I would love to update JRuby to the latest release, however there are some outstanding bugs in running its test suite etc, so I was not yet able to update them. But it is definitely work in progress.
Comment 2 Bohuslav "Slavek" Kabrda 2013-03-13 03:01:27 EDT
For Fedora 18, this is no longer an option. Hoewever Fedora 19 will ship with JRuby 1.7.2, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.