Bug 840700 - Remove XML content from Fixed URL's
Remove XML content from Fixed URL's
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-16 21:26 EDT by Lee Newson
Modified: 2013-06-06 21:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.26.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 21:29:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2012-07-16 21:26:21 EDT
Currently if a title has XML elements in it, eg "Hello <literal>World</literal>" the fixed URL would be Hello_literalWorldliteral. As such the XML Elements should be stripped from the XML as well.
Comment 1 Lee Newson 2012-07-16 21:50:13 EDT
Fixed in 0.26.0

The builder will now remove XML elements from the Fixed URL's when it creates them.

Cause:

XML Elements weren't removed from the string before the it was escaped (or at all for that matter)

Consequence:

The fixed URL's were created with the XML element names in the URL. Since the XML is used for formatting and styling only this made the URL messy.

Fix:

Remove the XML elements from the string before it is escaped. See the createURLTitle() method in the DocbookBuilder class for more information.
Comment 2 Lee Newson 2013-06-06 21:29:10 EDT
Closing and setting as current release as no QA was performed by the original reporter. If there is still an issue with this bug still than please re-open it.

Note You need to log in before you can comment on or make changes to this bug.