Bug 840724 - Group activity page: AttributeError: 'NoneType' object has no attribute 'display_name'
Group activity page: AttributeError: 'NoneType' object has no attribute 'disp...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.1
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks: 747000
  Show dependency treegraph
 
Reported: 2012-07-17 01:19 EDT by Dan Callaghan
Modified: 2014-12-07 20:13 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 20:38:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-07-17 01:19:27 EDT
Version-Release number of selected component (if applicable):
beaker-server-0.9.1-1.el6eng.noarch

Tried to view /activity/groups:

2012-07-17 01:04:02,289 cherrypy.msg INFO HTTP: Page handler: <bound method Activities.group of <bkr.server.activity.Activities object at 0x7f5f2a61b410>>
Traceback (most recent call last):
...
  File "build/lib/bkr/server/templates/my_paginate_datagrid.py", line 165, in _pull
  File "/usr/lib/python2.6/site-packages/turbogears/widgets/datagrid.py", line 66, in get_field
    return self.getter(row)
  File "/usr/lib/python2.6/site-packages/bkr/server/activity.py", line 132, in <lambda>
    widgets.PaginateDataGrid.Column(name='object_name', getter=lambda x: x.object_name(), title='Object', options=dict(sortable=False)),
  File "/usr/lib/python2.6/site-packages/bkr/server/model.py", line 3089, in object_name
    return "Group: %s" % self.object.display_name
AttributeError: 'NoneType' object has no attribute 'display_name'
Error in code generated from template file 'build/lib/bkr/server/templates/grid.kid'

rmancy theorised that this is because the group has been deleted but its activity rows remain.
Comment 1 Raymond Mancy 2012-07-17 05:09:55 EDT
This is correct. It's an existing bug,and I'd say we've just been lucky that we haven't hit it before.

It should be solved by this patch here http://gerrit.beaker-project.org/#/c/1216/
Comment 2 Dan Callaghan 2012-07-17 21:05:00 EDT
Needed for bug 747000
Comment 3 Dan Callaghan 2012-07-19 20:38:36 EDT
Beaker 0.9.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.