Bug 840731 - Validation warning disappears when navigating to different row
Validation warning disappears when navigating to different row
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.6.1
Unspecified Linux
high Severity medium
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 02:03 EDT by Hedda Peters
Modified: 2012-11-07 01:18 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.7.4-SNAPSHOT (20120927-0015)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 01:18:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-07-17 02:03:50 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build Identifier: 

When using Ctrl + Enter to move into the next string and that string contains a validation warning, this warning will only be shown briefly and then disappears.

Reproducible: Always

Steps to Reproduce:
1. Assume subsequent strings A, B, C...
2. Introduce a tag error into string B and save.
3. Open string A
4. Use Ctrl+Enter to save string A and move to string B

Actual Results:  
The validation warning for the tag error in string B appears briefly, then disappears.

Expected Results:  
The validation warning should remain visible

Other ways of accessing string B (e.g. by clicking into it with mouse, or by using Alt + down arrow) do not show this problem, the warning remains visible.
Comment 1 Hedda Peters 2012-07-19 21:23:23 EDT
Correction:

I now think it happens regardless of the method you use to open string B. But it only happens when you've made a change in string A before changing into string B.

So:

Make a change in string A. Open string B using any method (mouse click into it, or hitting Ctrl+Enter, ...). Result: The validation error in string B shows briefly then disappears.
Comment 2 Runa Bhattacharjee 2012-07-30 08:12:27 EDT
Assigning to Zanata Dev Team for evaluation
Comment 3 Patrick Huang 2012-09-25 22:10:33 EDT
can not reproduce in 2.0 new editor. I remember I had to fix something while implementing the new editor. The issue is occasionally we are comparing source sting and target string on different row. i.e. comparing A source to B target during switching rows. Anyway it seems fixed.
Comment 4 Ding-Yi Chen 2012-09-26 23:58:48 EDT
VERIFIED with Zanata version 1.7.4-SNAPSHOT (20120927-0015)
Zanata version 1.8.0-SNAPSHOT (20120927-0027)
Comment 5 Sean Flanigan 2012-11-07 01:18:25 EST
Fix released in Zanata 2.0.

Note You need to log in before you can comment on or make changes to this bug.