Bug 840747 - vmstat always reports zero for 'si' and 'so' columns if your units are set to MiB (-SM)
vmstat always reports zero for 'si' and 'so' columns if your units are set to...
Status: CLOSED DUPLICATE of bug 851664
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jan Rybar
BaseOS QE - Apps
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 03:08 EDT by Mike Hamrick
Modified: 2016-10-31 09:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-31 09:49:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Working vmstat.c patch against procps-3.2.8-23.el6.src.rpm (1.67 KB, application/octet-stream)
2012-07-17 03:08 EDT, Mike Hamrick
no flags Details

  None (edit)
Description Mike Hamrick 2012-07-17 03:08:19 EDT
Created attachment 598570 [details]
Working vmstat.c patch against procps-3.2.8-23.el6.src.rpm

Description of problem:

The vmstat 'si' and 'so' columns are always zero if you run vmstat with -SM.

Version-Release number of selected component (if applicable):

procps-3.2.8-23.el6.x86_64

Steps to Reproduce:
1. vmstat -SM 1
2. cause swapping activity in another window
3. flip back to vmstat window, observe 'swpd' incrementing but not 'si' and 'so'.
  
Actual results:

The 'swpd' column changes, but 'si' and 'so' always remain zero.

Expected results:

I'd expect to see the 'si' and 'so' columns change with the 'swpd' column.

Additional info:

unitConvert is incorrectly being applied to kb_per_page and not *pswpin * kb_per_page.  The problem is kb_per_page is a small number, maybe 4.  You convert that to MiB and you're always going to get an integer zero, which causes the whole calculation to be zero.  The right thing to do is convert *psppwin * kb_per_page to MiB.
Comment 2 Jaromír Cápík 2012-07-31 10:16:03 EDT
Hello Mike.

I recently fixed exactly the same issue in RHEL5. My patch is almost identical to yours (I just additionally changed the unitConvert input type to long). Anyway, that confirms the solution is reasonable and should work correctly.
Thanks for reporting.

Best regards,
Jaromir.
Comment 3 RHEL Product and Program Management 2012-09-07 01:12:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 7 Jan Rybar 2016-10-31 09:49:15 EDT
Already fixed in 3.2.8-24
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=851664

*** This bug has been marked as a duplicate of bug 851664 ***

Note You need to log in before you can comment on or make changes to this bug.