This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 840788 - rbtdb.c:1511: INSIST(!((void *)((node)->deadlink.prev) != (void *)(-1))) failed, back trace
rbtdb.c:1511: INSIST(!((void *)((node)->deadlink.prev) != (void *)(-1))) fail...
Status: CLOSED DUPLICATE of bug 837165
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind (Show other bugs)
6.3
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Adam Tkac
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 04:36 EDT by Robert Scheck
Modified: 2013-04-30 19:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 07:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2012-07-17 04:36:37 EDT
Description of problem:
Jul 17 05:43:18 tux named[2205]: dispatch 0x7fcdac2954f0: open_socket(0.0.0.0#4321) -> permission denied: continuing
Jul 17 06:59:00 tux named[2205]: rbtdb.c:1511: INSIST(!((void *)((node)->deadlink.prev) != (void *)(-1))) failed, back trace
Jul 17 06:59:00 tux named[2205]: #0 0x7fcdc10bdc2f in ??
Jul 17 06:59:00 tux named[2205]: #1 0x7fcdbfa7489a in ??
Jul 17 06:59:00 tux named[2205]: #2 0x7fcdc094d700 in ??
Jul 17 06:59:00 tux named[2205]: #3 0x7fcdc094de77 in ??
Jul 17 06:59:00 tux named[2205]: #4 0x7fcdc095aacb in ??
Jul 17 06:59:00 tux named[2205]: #5 0x7fcdc09087e3 in ??
Jul 17 06:59:00 tux named[2205]: #6 0x7fcdc09b0a08 in ??
Jul 17 06:59:00 tux named[2205]: #7 0x7fcdc09b64c0 in ??
Jul 17 06:59:00 tux named[2205]: #8 0x7fcdbfa932f8 in ??
Jul 17 06:59:00 tux named[2205]: #9 0x7fcdbf448851 in ??
Jul 17 06:59:00 tux named[2205]: #10 0x7fcdbe9ab67d in ??
Jul 17 06:59:00 tux named[2205]: exiting (due to assertion failure)

Version-Release number of selected component (if applicable):
bind-9.8.2-0.10.rc1.el6.x86_64

How reproducible:
Unfortunately unknown, just happened after running for 4 days and hitting
a lot of DNS queries by clients.

Actual results:
Crashing BIND - causing lots of trouble.

Expected results:
BIND should not crash anymore.

Additional info:
BIND configuration as follows (without comments and IP replaced):

--- snipp ---
logging
{
	category lame-servers { null; };
	category edns-disabled { null; };
};

options
{
	directory		"/var/named";
	dump-file		"data/cache_dump.db";
	statistics-file		"data/named_stats.txt";
	memstatistics-file	"data/named_mem_stats.txt";
	zone-statistics		yes;
	notify no;
	transfer-format many-answers;
	interface-interval 0;
	allow-query { any; };
	listen-on port 53 { 127.0.0.1; 10.2.3.4; };
	dnssec-enable yes;
	dnssec-validation yes;
	dnssec-lookaside auto;
	bindkeys-file "/etc/named.iscdlv.key";
	managed-keys-directory "/var/named/dynamic";
};

view "internal-in" in
{
	recursion yes;
	additional-from-auth yes;
	additional-from-cache yes;
	allow-query { any; };

	zone "." in
	{
		type hint;
		file "named.ca";
	};

	include "/etc/named.rfc1912.zones";
	include "/etc/named.root.key";
};
--- snapp ---
Comment 2 Adam Tkac 2012-07-18 07:50:43 EDT

*** This bug has been marked as a duplicate of bug 837165 ***

Note You need to log in before you can comment on or make changes to this bug.