Bug 840807 - ISE when setting "Display items per page" for an Organization in tab "Software Channel Entitlements"
ISE when setting "Display items per page" for an Organization in tab "Softw...
Status: CLOSED DUPLICATE of bug 831145
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 05:37 EDT by Dimitar Yordanov
Modified: 2012-09-21 09:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 05:52:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-07-17 05:37:08 EDT
Description of problem:
ISE when setting "Display items per page"  for an Organization in  tab "Software Channel Entitlements"

Version-Release number of selected component (if applicable):
Satellite 5.5.0
Satellite 5.4.1

How reproducible:
100 %


Steps to Reproduce:
1. Create New Organization
   Admin -> Oraganizations -> create new organization
Organizations 
2. Get to Tab "Software Channel Entitlements"
3. Set "Display items per page" to 500
4. Set "Display items per page" to 250

Actual results:
Internal Server Error


Additional info:
###  /var/log/tomcat*/catalina.out   ##########################################
Tue_Jul_17_2012_05_29_06
2012-07-17 05:29:23,190 [TP-Processor8] ERROR com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction. Rolling back
java.lang.IllegalStateException: Parameter count exceeded allowed maximum: 512
	at org.apache.tomcat.util.http.Parameters.addParam(Parameters.java:335)
	at org.apache.tomcat.util.http.Parameters.processParameters(Parameters.java:456)
	at org.apache.tomcat.util.http.Parameters.processParameters(Parameters.java:365)
	at org.apache.catalina.connector.Request.parseParameters(Request.java:2593)
	at org.apache.catalina.connector.Request.getParameter(Request.java:1064)
	at org.apache.catalina.connector.RequestFacade.getParameter(RequestFacade.java:355)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.addParameterizedMessages(EnvironmentFilter.java:112)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:105)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
	at java.lang.Thread.run(Thread.java:736)
Tue_Jul_17_2012_05_29_06
Comment 1 Tomas Lestach 2012-07-17 05:52:04 EDT
I fixed this issue couple of days ago ...

*** This bug has been marked as a duplicate of bug 831145 ***

Note You need to log in before you can comment on or make changes to this bug.