Bug 840830 - Ship %{_libdir}/pkgconfig/ijs.pc
Ship %{_libdir}/pkgconfig/ijs.pc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 832130
  Show dependency treegraph
 
Reported: 2012-07-17 06:37 EDT by Jiri Popelka
Modified: 2012-07-17 09:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: ghostscript-9.05-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-17 09:41:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Popelka 2012-07-17 06:37:09 EDT
cups-filters-1.0.19 uses
PKG_CHECK_MODULES([IJS], [ijs])
macro to find module providing libijs.

We ship libijs in ghostscript, but don't ship
%{_libdir}/pkgconfig/ijs.pc
so running configure in cups-filters ends up with:

checking for IJS... no
configure: error: Package requirements (ijs) were not met:
No package 'ijs' found
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.
Alternatively, you may set the environment variables IJS_CFLAGS
and IJS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Shipping that pkgconfig file fixes the problem.
Is there any reason we haven't done so ?

=== Suggested fix ===
diff --git a/ghostscript.spec b/ghostscript.spec
@@ -241,9 +241,8 @@
 # Documentation
 install -m0644 doc/COPYING $RPM_BUILD_ROOT%{_docdir}/%{name}-%{gs_dot_ver}
 
-# Don't ship pkgconfig or libtool la files.
-rm -f $RPM_BUILD_ROOT%{_libdir}/pkgconfig/ijs.pc \
-        $RPM_BUILD_ROOT%{_libdir}/libijs.la
+# Don't ship libtool la files.
+rm -f $RPM_BUILD_ROOT%{_libdir}/libijs.la
 
 # Don't ship ijs example client or server
 rm -f $RPM_BUILD_ROOT%{_bindir}/ijs_{client,server}_example
@@ -325,6 +324,7 @@
 %dir %{_includedir}/ijs
 %{_includedir}/ijs/*
 %{_bindir}/ijs-config
+%{_libdir}/pkgconfig/ijs.pc
 %{_libdir}/libijs.so
 %{_libdir}/libgs.so
Comment 1 Jiri Popelka 2012-07-17 06:45:28 EDT
Note:

cups-filters < 1.0.19
used to use the following code (configure.ac) to find libijs

AC_CHECK_LIB(ijs,main,
  [ IJS_LIBS=-lijs],
  [ echo "*** ijs library not found. ***";exit ]
)
AC_SUBST(IJS_LIBS)

which was OK with ghostscript.
Comment 2 Tim Waugh 2012-07-17 09:41:50 EDT
I think the only reason we didn't do it was because nothing needed it.

Note You need to log in before you can comment on or make changes to this bug.