Bug 840837 - mysql-5.5.25a-1.fc18 is failing tests on ARM
mysql-5.5.25a-1.fc18 is failing tests on ARM
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
rawhide
arm9 Unspecified
high Severity high
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-07-17 06:59 EDT by Peter Robinson
Modified: 2012-07-18 09:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 09:04:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-07-17 06:59:20 EDT
mysql-5.5.25a-1.fc18 fails to build on ARM because it's failing some tests. mysql 5.5.24 built fine on ARM so it's a regression in the latest release.

Failed build is: http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=977031

Details are:

+ make test
Running tests...
Test project /builddir/build/BUILD/mysql-5.5.25a
      Start  1: pfs_instr_class
 1/12 Test  #1: pfs_instr_class ..................   Passed    0.07 sec
      Start  2: pfs_instr_class-oom
 2/12 Test  #2: pfs_instr_class-oom ..............   Passed    0.01 sec
      Start  3: pfs_instr
 3/12 Test  #3: pfs_instr ........................   Passed    0.02 sec
      Start  4: pfs_instr-oom
 4/12 Test  #4: pfs_instr-oom ....................   Passed    0.01 sec
      Start  5: pfs
 5/12 Test  #5: pfs ..............................   Passed    0.06 sec
      Start  6: bitmap
 6/12 Test  #6: bitmap ...........................   Passed    6.02 sec
      Start  7: base64
 7/12 Test  #7: base64 ...........................   Passed    0.22 sec
      Start  8: my_vsnprintf
 8/12 Test  #8: my_vsnprintf .....................   Passed    0.03 sec
      Start  9: my_atomic
 9/12 Test  #9: my_atomic ........................***Exception: Other  0.04 sec
      Start 10: my_rdtsc
10/12 Test #10: my_rdtsc .........................   Passed    0.03 sec
      Start 11: lf
11/12 Test #11: lf ...............................   Passed    2.36 sec
      Start 12: my_malloc
12/12 Test #12: my_malloc ........................   Passed    0.02 sec
92% tests passed, 1 tests failed out of 12
Total Test time (real) =   9.16 sec
The following tests FAILED:
	  9 - my_atomic (OTHER_FAULT)
Errors while running CTest
make: *** [test] Error 8
Comment 1 Honza Horak 2012-07-18 04:30:45 EDT
I'm a bit confused now. I tried several builds of mysql-5.5.25a and older mysql-5.5.24 and all failed on armv5tel with the error above. After then I noticed a successful build [1] with the same packages in buildroot, but in a different mock environment. Peter, can you provide some info, what is the trick to make the build working?

[1] http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=977552
Comment 2 Peter Robinson 2012-07-18 04:38:56 EDT
what commands are you using?
Comment 3 Honza Horak 2012-07-18 04:57:04 EDT
(In reply to comment #2)
> what commands are you using?

arm-koji build --scratch f18 mysql-5.5.25a-1.fc18.src.rpm
Comment 4 Peter Robinson 2012-07-18 09:04:53 EDT
Gah! Sorry, it seems that the 3 builds I saw fail were due to a host issue(s) which I some how managed to get the same host.

The build command is correct btw. 

Sorry for the noise

Note You need to log in before you can comment on or make changes to this bug.