Bug 840844 - Authentication is required when powering off but no user is logged in
Authentication is required when powering off but no user is logged in
Status: CLOSED DUPLICATE of bug 890827
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 07:22 EDT by Jociel Andrade
Modified: 2013-01-14 15:30 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 15:30:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jociel Andrade 2012-07-17 07:22:48 EDT
Description of problem:
When I click to shutdown my system, a dialog box is showed requesting authentication and warning that "uthentication is required for powering off the system while other users are logged in", but nobody is logged in.

Version-Release number of selected component (if applicable):
Fedora Linux 17 (kernel 3.4.4-5.fc17.x86_64)
The system is up to date.

Steps to Reproduce:
1. Click on power off button on authentication screen.
  
Actual results:
A dialog box is showed requiring authentication.

Expected results:
The dialog box shouldn't showed because nobody is logged in.

Additional info:
For more information, please, ask me.
Comment 1 Michal Schmidt 2012-07-17 11:36:41 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1. Click on power off button on authentication screen.

Not sure what you mean by "authentication screen" here. The gdm login screen?

Please login, run the "loginctl" command and paste the output here.
Comment 2 Jociel Andrade 2012-07-17 22:25:10 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Steps to Reproduce:
> > 1. Click on power off button on authentication screen.
> 
> Not sure what you mean by "authentication screen" here. The gdm login screen?
> 
> Please login, run the "loginctl" command and paste the output here.

Ops... "loginctl" listed the user logged in ("plex"). I installed plex media server that run the server with user "plex" on start up.
I'm so sorry for open this ticket. Excuse-me.
You can change this ticket as invalid.

Congratulations to the team behind Fedora/Linux/Gnome3 for the beautiful work.
Comment 3 Michal Schmidt 2012-07-18 04:00:42 EDT
No problem. Thanks for the report.
Comment 4 Julian Sikorski 2012-12-31 05:45:40 EST
I started seeing this with Fedora 18. I just log in normally via gdb, and need to give root password to shut the machine down:

$ loginctl
   SESSION        UID USER             SEAT            
         2        500 julas            seat0           
         3          0 root                             
         5        500 julas            seat0           
         9        500 julas            seat0

I am assuming that session 3 is the culprit, but where could it be coming from? sudo perhaps?
Comment 5 Michal Schmidt 2013-01-07 07:43:17 EST
(In reply to comment #4)
> I am assuming that session 3 is the culprit, but where could it be coming
> from? sudo perhaps?

See "loginctl session-status 3".
Comment 6 Julian Sikorski 2013-01-07 12:50:28 EST
On a second thought, it seems it has less to do with sudo and more with logging out and then back in:

         2        500 julas            seat0           
         3          0 root                             
         5        500 julas            seat0           
         7        500 julas            seat0           
2 - julas (500)
	   Since: Mon, 2013-01-07 17:54:42 CET; 54min ago
	  Leader: 1356
	    Seat: seat0; vc1
	 Display: :0
	 Service: gdm-password; type x11; class user
	   State: closing
	  CGroup: name=systemd:/user/julas/2
		  ├ 1558 /usr/bin/pulseaudio --start
		  ├ 1569 /usr/libexec/pulse/gconf-helper
		  └ 2011 /usr/libexec/tracker-extract
3 - root (0)
	   Since: Mon, 2013-01-07 18:01:01 CET; 47min ago
	  Leader: 3024
	 Service: crond; type unspecified; class user
	   State: closing
	  CGroup: name=systemd:/user/root/3
		  └ 3036 /usr/sbin/anacron -s
5 - julas (500)
	   Since: Mon, 2013-01-07 18:46:26 CET; 2min 31s ago
	  Leader: 12076
	    Seat: seat0; vc1
	 Display: :1
	 Service: gdm-password; type x11; class user
	   State: closing
	  CGroup: name=systemd:/user/julas/5
		  └ 12726 /usr/libexec/tracker-extract
7 - julas (500)
	   Since: Mon, 2013-01-07 18:47:07 CET; 1min 54s ago
	  Leader: 12841 (gdm-session-wor)
	    Seat: seat0; vc1
	 Display: :2
	 Service: gdm-password; type x11; class user
	   State: active
	  CGroup: name=systemd:/user/julas/7
		  ├ 12841 gdm-session-worker [pam/gdm-password]
		  ├ 12850 /usr/bin/gnome-keyring-daemon --daemonize --login
		  ├ 12852 gnome-session
		  ├ 12861 dbus-launch --sh-syntax --exit-with-session
		  ├ 12862 /bin/dbus-daemon --fork --print-pid 5 --print-addr...
		  ├ 12874 /usr/libexec/imsettings-daemon
		  ├ 12877 /usr/libexec/gvfsd
		  ├ 12881 /usr/libexec//gvfsd-fuse -f /run/user/500/gvfs
		  ├ 12966 /usr/libexec/at-spi-bus-launcher
		  ├ 12970 /bin/dbus-daemon --config-file=/etc/at-spi2/access...
		  ├ 12974 /usr/libexec/at-spi2-registryd --use-gnome-session...
		  ├ 12981 /usr/libexec/gconfd-2
		  ├ 12988 /usr/libexec/gnome-settings-daemon
		  ├ 13004 /usr/libexec/gvfs-udisks2-volume-monitor
		  ├ 13008 /usr/libexec/gvfs-afc-volume-monitor
		  ├ 13013 /usr/libexec/gvfs-gphoto2-volume-monitor
		  ├ 13016 /usr/bin/gnome-shell
		  ├ 13019 /usr/libexec/gsd-input-sources-switcher
		  ├ 13024 /usr/libexec/gsd-printer
		  ├ 13029 /usr/libexec/dconf-service
		  ├ 13039 /usr/libexec/evolution/3.6/evolution-alarm-notify
		  ├ 13040 nm-applet
		  ├ 13042 /usr/libexec/tracker-miner-fs
		  ├ 13043 abrt-applet
		  ├ 13044 /usr/libexec/gnome-user-share
		  ├ 13051 /usr/libexec/deja-dup/deja-dup-monitor
		  ├ 13054 /bin/sh /usr/libexec/syncevo-dbus-server-startup.s...
		  ├ 13059 zeitgeist-datahub
		  ├ 13062 sleep 120
		  ├ 13063 /usr/libexec/tracker-store
		  ├ 13065 /usr/bin/seapplet
		  ├ 13083 /usr/bin/zeitgeist-daemon
		  ├ 13111 /usr/libexec/zeitgeist-fts
		  ├ 13114 /bin/cat
		  ├ 13149 /usr/libexec/evolution-source-registry
		  ├ 13167 /usr/libexec/gvfsd-metadata
		  ├ 13171 /usr/libexec/goa-daemon
		  ├ 13179 /usr/libexec/gnome-shell-calendar-server
		  ├ 13188 /usr/libexec/evolution-calendar-factory
		  ├ 13196 /usr/libexec/mission-control-5
		  ├ 13218 /usr/libexec/gvfsd-trash --spawner :1.3 /org/gtk/g...
		  ├ 13230 /bin/sh /usr/libexec/gnome-documents-search-provid...
		  ├ 13231 /usr/bin/gjs-console -I /usr/share/gnome-documents...
		  ├ 13252 /usr/libexec/telepathy-logger
		  ├ 13257 /usr/libexec/evolution-addressbook-factory
		  ├ 13272 /usr/libexec/telepathy-gabble
		  ├ 13299 gnome-terminal
		  ├ 13305 gnome-pty-helper
		  ├ 13306 bash
		  └ 13517 loginctl session-status 7
Comment 7 Lennart Poettering 2013-01-14 15:30:13 EST

*** This bug has been marked as a duplicate of bug 890827 ***

Note You need to log in before you can comment on or make changes to this bug.