Bug 840859 - SAM cli command displays errors
SAM cli command displays errors
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On: 839524
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 08:10 EDT by Eric Sammons
Modified: 2013-03-27 16:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 839524
Environment:
Last Closed: 2012-11-01 13:33:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Sammons 2012-07-17 08:10:27 EDT
+++ This bug was initially created as a clone of Bug #839524 +++

Description of problem:
SAM packages installed on fedora-16
The WEBUI is visible . But, the cli command fails

Version-Release number of selected component (if applicable):
[root@nec-em15 x86_64]# cat /etc/issue
Fedora release 16 (Verne)
Kernel \r on an \m (\l)


[root@nec-em15 x86_64]# rpm -qa | grep katello
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-0.2.42-1.git.26.3d87775.fc16.noarch
katello-selinux-0.2.6-1.git.0.c9816da.fc16.noarch
katello-cli-headpin-0.1.19-1.git.0.9520f16.fc16.noarch
katello-headpin-0.2.21-1.git.0.da563b9.fc16.noarch
katello-certs-tools-1.1.6-1.git.0.4878f30.fc16.noarch
katello-configure-0.2.29-1.git.0.7330d57.fc16.noarch
katello-common-0.2.44-1.git.73.3737e93.fc16.noarch
katello-headpin-all-0.2.21-1.git.0.da563b9.fc16.noarch
katello-glue-candlepin-0.2.44-1.git.73.3737e93.fc16.noarch


How reproducible:
yum install -y katello-headpin-all
katello-configure --deployment=sam

Steps to Reproduce:
1.headpin -u admin -p admin --help
2.The WEBUI can be accessed : admin/admin
  https://nec-em15.rhts.eng.bos.redhat.com/sam

  
Actual results:
the below command fails.

[root@nec-em15 x86_64]# headpin -u admin -p admin --help
  Traceback (most recent call last):
  File "/usr/bin/headpin", line 141, in <module>
    setup_admin(admin)
  File "/usr/bin/headpin", line 50, in setup_admin
    akey_cmd.add_action('create', activation_key.Create())
  AttributeError: 'ActivationKey' object has no attribute 'add_action'

Expected results:
the above cli command should display appropriate help for
all the supported commands



Additional info:
Comment 2 Tom McKay 2012-11-01 13:33:53 EDT
Works for me in latest

Note You need to log in before you can comment on or make changes to this bug.