Bug 840882 - Log button throws "PGError: ERROR: column reference "name" is ambiguous" for non admin user
Log button throws "PGError: ERROR: column reference "name" is ambiguous" for ...
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Tzu-Mainn Chen
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 09:49 EDT by Rehana
Modified: 2012-12-04 10:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An ambiguous database column caused an error when a standard user viewed the Logs page in Cloud Engine. This bug fix provides a specific column name. Users now view the Logs page without error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:15:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pg_error (204.32 KB, image/png)
2012-07-17 09:49 EDT, Rehana
no flags Details
Rails_log (19.64 KB, text/plain)
2012-07-17 09:55 EDT, Rehana
no flags Details

  None (edit)
Description Rehana 2012-07-17 09:49:07 EDT
Created attachment 598638 [details]
pg_error

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to conductor
2.create new user, say user A
3.create new group, say Group A
4.Add user A to Group A
5.Give group A "Global HWP Administrator" role
6. Now login as User A
7. go to monitor
8. click on Logs
  
Actual results:
PG error displays on conductor (PFA: pg_error.png, rails.log)


Expected results:
Should not display pg error, should list the correct info (as per the role, if any)

Additional info:

rpm -qa | grep aeolus
aeolus-configure-2.7.0-0.20120712224728gitcc8302d.fc16.noarch
rubygem-aeolus-cli-0.6.0-0.20120712224735gite2a391a.fc16.noarch
aeolus-conductor-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-daemons-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-all-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-doc-0.11.0-0.20120713030022git8c99e02.fc16.noarch
aeolus-conductor-devel-0.11.0-0.20120713030022git8c99e02.fc16.noarch
rubygem-aeolus-image-0.5.0-1.fc16.noarch
Comment 1 Rehana 2012-07-17 09:55:01 EDT
Created attachment 598639 [details]
Rails_log
Comment 2 Tzu-Mainn Chen 2012-07-30 11:45:00 EDT
Patch created:

http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-July/011731.html
Comment 3 Tzu-Mainn Chen 2012-07-31 13:52:38 EDT
Patch pushed to master:

commit 1c6c2a57c257cd78147ec577237cee54d7f888c1
Author: Tzu-Mainn Chen <tzumainn@redhat.com>
Date:   Mon Jul 30 11:25:34 2012 -0400

    BZ840882 fix indeterminate name column
Comment 5 Aziza Karol 2012-09-17 05:45:41 EDT
No error is displayed when the non admin user clicks on log button.

verified:
rpm -qa |grep aeolus
aeolus-conductor-0.13.7-1.el6cf.noarch
aeolus-all-0.13.7-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-conductor-doc-0.13.7-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.13.7-1.el6cf.noarch
Comment 7 errata-xmlrpc 2012-12-04 10:15:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.