This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 840885 - RFE: add yum langinstall command
RFE: add yum langinstall command
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-langpacks (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Petersen
Fedora Extras Quality Assurance
: FutureFeature, i18n
Depends On:
Blocks: 830563
  Show dependency treegraph
 
Reported: 2012-07-17 09:55 EDT by multiplicis
Modified: 2013-03-29 02:21 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 05:22:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description multiplicis 2012-07-17 09:55:26 EDT
Description of problem:
#yum groupinstall "Italian Support" 
gives to me this message:
"Warning: Group italian-support does not have any packages.
No packages in any requested group available to install or update"

Version-Release number of selected component (if applicable):
Fedora 17

How reproducible:
You have to install Fedora with default language set to "American English" and then try to install group "Italian Support".

Steps to Reproduce:
1.Install F17 by the KDE LiveCD
2.log as root
3.#yum groupinstall "Italian Support"
  
Actual results:
Warning: Group italian-support does not have any packages.
No packages in any requested group available to install or update

Expected results:


Additional info:
Comment 1 Rex Dieter 2012-07-17 10:22:54 EDT
I believe that's 'by design' that only stuff for your current locale gets installed (which in your case was American English), but we can get the scoop from yum-langpacks maintainer(s)
Comment 2 Bill Nottingham 2012-07-17 13:43:32 EDT
To install Italian language support, you need to either run yum in italian, or configure the langpacks plugin (/etc/yum/pluginconf.d/langpacks.conf).

These groups will be removed in a future release - having to hardcode all the language packages in comps just doesn't scale.
Comment 3 Jens Petersen 2012-07-17 22:37:35 EDT
(In reply to comment #2)
> To install Italian language support, you need to either run yum in italian,

eg You could run "LANG=it_IT.utf8 yum update", etc to trigger
yum-langpacks.

Note that if your desktop is not running in Italian anyway
you probably won't be able to make use of the Italian language
packs (for Libreoffice, etc, etc), so if you really want this
for yourself you are better off running your desktop in Italian
anyway for this to be useful.

It is not very obvious but in gnome-control-center you can
change your desktop language to Italian and then restart
your desktop for it to take effect.
Comment 4 Jens Petersen 2012-07-23 23:44:13 EDT
So to conclude, I think this is the expected behaviour
and this bug could be closed.

Are there any particular Italian packages you were after?
Comment 5 Germano Massullo 2012-07-24 05:31:17 EDT
Could it be related tohttps://bugzilla.redhat.com/show_bug.cgi?id=830563  ?
Comment 6 Pravin Satpute 2012-07-25 07:04:35 EDT
I can see that 

comps-f16 has

  <group>
    <id>italian-support</id>
    <_name>Italian Support</_name>
    <_description/>
    <default>false</default>
    <uservisible>true</uservisible>
    <langonly>it</langonly>
    <packagelist>
      <packagereq type="conditional" requires="aspell">aspell-it</packagereq>
      <packagereq type="conditional" requires="autocorr-en">autocorr-it</packagereq>
      <packagereq type="conditional" requires="childsplay">childsplay-alphabet_sounds_it</packagereq>
      <packagereq type="conditional" requires="eclipse-platform">eclipse-nls-it</packagereq>
      <packagereq type="conditional" requires="gcompris">gcompris-sound-it</packagereq>
      <packagereq type="conditional" requires="hunspell">hunspell-it</packagereq>
      <packagereq type="conditional" requires="hyphen">hyphen-it</packagereq>
      <packagereq type="conditional" requires="kdelibs3">kde-i18n-Italian</packagereq>
      <packagereq type="conditional" requires="kdelibs">kde-l10n-Italian</packagereq>
      <packagereq type="conditional" requires="koffice-core">koffice-langpack-it</packagereq>
      <packagereq type="conditional" requires="LabPlot-doc">LabPlot-doc-it</packagereq>
      <packagereq type="conditional" requires="libreoffice-core">libreoffice-langpack-it</packagereq>
      <packagereq type="conditional" requires="man-pages">man-pages-it</packagereq>
      <packagereq type="conditional" requires="moodle">moodle-it</packagereq>
      <packagereq type="conditional" requires="mythes-en">mythes-it</packagereq>
      <packagereq type="conditional" requires="nqc-doc">nqc-doc-it</packagereq>
      <packagereq type="conditional" requires="tkgate">tkgate-it</packagereq>
    </packagelist>
  </group>


on the other hand has nothing in comps-f17 ?

  <group>
    <id>italian-support</id>
    <_name>Italian Support</_name>
    <_description/>
    <default>false</default>
    <uservisible>true</uservisible>
    <langonly>it</langonly>
    <packagelist>
    </packagelist>
  </group>
Comment 7 Rex Dieter 2012-07-25 07:31:31 EDT
correct, f17+ uses yum-langpacks instead, and not comps conditionals anymore
Comment 8 Pravin Satpute 2012-07-25 08:09:22 EDT
any chance so that yum groupinstall "xyz-support"  will automatically run yum-langpacks as well?

In above case yum-langpacks will become backward compatible.
Comment 9 Bill Nottingham 2012-07-25 16:01:25 EDT
Unlikely, because (among other reasons) it would require a <lang name> -> <lang code> mapping.

Adding a 'langinstall' option might be simpler.
Comment 10 Jens Petersen 2012-07-25 20:46:29 EDT
(In reply to comment #9)
> Adding a 'langinstall' option might be simpler.

Right.  Would that code live in yum-langpacks?
Comment 11 Jens Petersen 2012-07-25 20:48:13 EDT
*** Bug 830563 has been marked as a duplicate of this bug. ***
Comment 12 Kevin Kofler 2012-07-26 04:07:35 EDT
> Unlikely, because (among other reasons) it would require a <lang name> -> <lang
> code> mapping.

Isn't that what the <langonly>it</langonly> tag in comps is for?
Comment 13 Bill Nottingham 2012-07-26 12:22:38 EDT
The implicat(In reply to comment #12)
> > Unlikely, because (among other reasons) it would require a <lang name> -> <lang
> > code> mapping.
> 
> Isn't that what the <langonly>it</langonly> tag in comps is for?

The implication was that this sort of backwards compatibility option would work even if the group didn't exist.
Comment 14 Bill Nottingham 2012-08-08 15:36:25 EDT
I've added langinstall, langremove, and langlist commands to yum-langpacks-0.3.0, and am pushing it to F-18 and F-17. Please let me know how this works for you.
Comment 15 Fedora Update System 2012-08-08 15:56:20 EDT
yum-langpacks-0.3.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-langpacks-0.3.0-1.fc17
Comment 16 Fedora Update System 2012-08-09 18:54:54 EDT
Package yum-langpacks-0.3.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-langpacks-0.3.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11567/yum-langpacks-0.3.0-1.fc17
then log in and leave karma (feedback).
Comment 17 Pravin Satpute 2012-08-13 11:18:36 EDT
thanks for update, tested it.

$yum langinstall mr_IN 
doing expected thing, i.e install hunspell-mr and libreoffice-*-mr

but 
$yum groupinstall marathi-support

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 319, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 185, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1140, in buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/langpacks.py", line 303, in postresolve_hook
    add_matches_from_ts(conduit, group.langonly)
TypeError: add_matches_from_ts() takes exactly 3 arguments (2 given)
Comment 18 Fedora Update System 2012-08-13 16:14:39 EDT
yum-langpacks-0.3.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-langpacks-0.3.0-2.fc17
Comment 19 Parag Nemade 2012-08-14 02:15:25 EDT
1) With the new update langinstall works fine. But, my question is will "yum grouplist" will continue to show "Marathi Support" as a available group to install? 

2)Also, following is expected results right? groupinstall is not working.

$sudo yum groupinstall "Marathi Support" 
Loaded plugins: langpacks, presto, refresh-packagekit
Package ibus-m17n-1.3.3-11.fc17.x86_64 already installed and latest version
Warning: Group marathi-support does not have any packages.
No packages in any requested group available to install or update

3) Why is it that "yum langinstall mr_IN" works without root access whereas yum groupinstall used to need root access?
Comment 20 Fedora Update System 2012-08-14 05:22:35 EDT
yum-langpacks-0.3.0-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Bill Nottingham 2012-08-14 10:43:19 EDT
(In reply to comment #19)
> 1) With the new update langinstall works fine. But, my question is will "yum
> grouplist" will continue to show "Marathi Support" as a available group to
> install? 

The groups are likely to be removed soon - input methods merged into the input-methods group, and fonts into the font group.

> 2)Also, following is expected results right? groupinstall is not working.
> 
> $sudo yum groupinstall "Marathi Support" 
> Loaded plugins: langpacks, presto, refresh-packagekit
> Package ibus-m17n-1.3.3-11.fc17.x86_64 already installed and latest version
> Warning: Group marathi-support does not have any packages.
> No packages in any requested group available to install or update

That's expected if the ony things in the group are already installed.

> 3) Why is it that "yum langinstall mr_IN" works without root access whereas
> yum groupinstall used to need root access?

Because I forgot to add a permissions check. Oops.

Note You need to log in before you can comment on or make changes to this bug.