Bug 840890 - Preserving disks causes anaconda to fail to write a LUKS encrypted PV
Preserving disks causes anaconda to fail to write a LUKS encrypted PV
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks: 670971 1023566 1056248
  Show dependency treegraph
 
Reported: 2012-07-17 10:14 EDT by Matthew Mosesohn
Modified: 2014-10-14 02:38 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.21.220-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 02:38:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Mosesohn 2012-07-17 10:14:23 EDT
Description of problem:
I am trying to install off an ISO located on /boot (sda1) as a recovery method, preserving existing disks.  The install needs to preserve data on sda1, use an ISO on sda1, and wipe and replace sda2 with an LVM partition containing a series of defined partitions.

Version-Release number of selected component (if applicable):
RHEL 6.3

How reproducible:
Always

Steps to Reproduce:
1. Install a system normally with a 3GB /boot
2. Load in install media and required components to boot from disk on /boot. (Will post files to this bz)
3. Run installation
  
Actual results:
The install fails on configuring disks

Expected results:
The LUKS portion shouldn't fail, and the install should proceed.

Additional info:
If you remove the --encrypted and volume_key elements from the pv definition, the partitioning succeeds.
Comment 5 David Lehman 2012-07-31 11:43:30 EDT
Here's a link to an updates image containing a proposed fix:

  http://dlehman.fedorapeople.org/updates/updates-840890.0.img


If you want to use it from there, just add the following to your boot command line:

  updates=http://dlehman.fedorapeople.org/updates/updates-840890.0.img


Let me know how it works.
Comment 6 Matthew Mosesohn 2012-07-31 12:29:12 EDT
David,

I don't see any change in behavior. Would you like a new traceback? It looks quite the same.
Comment 7 Matthew Mosesohn 2012-07-31 12:31:46 EDT
Also, the logs say "failed to mount loopback dvice /dev/loop7 on /tmp/update-disk as /tmp/updates.img: (null)".

It does save the updates image and it is located in /tmp/update-disk (the autopart_type.py file).  

Any other recommendations?
Comment 8 David Lehman 2012-07-31 15:19:11 EDT
Sorry about that -- the updates I sent earlier had the wrong patch applied.

Here's a new one:

  http://dlehman.fedorapeople.org/updates/updates-840890.1.img


If you want to use it from there, just add the following to your boot command line:

  updates=http://dlehman.fedorapeople.org/updates/updates-840890.1.img


(Note the .1 where there was a .0 in the first image.)

Let me know how it works.
Comment 9 Matthew Mosesohn 2012-07-31 17:15:11 EDT
David,

Great work!!  It fixes the issues with writing over an existing LUKS partition or writing a new partition (existing sda2 with LUKS or no sda2 at all).  That covers both scenarios I might run into. Thanks a ton!

I'm still running into issues with it finding the ISO image now, but we can take that conversation offline.
Comment 12 RHEL Product and Program Management 2013-05-06 17:17:44 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 15 Jan Stodola 2014-08-12 10:45:37 EDT
Reproduced with RHEL-6.5, retested with anaconda-13.21.224-1.el6, compose RHEL-6.6-20140731.1. Kickstart installation was successful and encrypted PV created.

Moving to VERIFIED.
Comment 16 errata-xmlrpc 2014-10-14 02:38:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1380.html

Note You need to log in before you can comment on or make changes to this bug.