Bug 840894 - Liferay quick-start: Error
Liferay quick-start: Error
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
: Triaged
: 846183 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 10:19 EDT by Attila Nagy
Modified: 2015-05-14 22:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 15:26:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (410.88 KB, text/x-log)
2012-07-17 10:21 EDT, Attila Nagy
no flags Details
Server Logs (27.34 KB, application/x-gzip)
2012-07-21 03:13 EDT, Kamesh Sampath
no flags Details

  None (edit)
Description Attila Nagy 2012-07-17 10:19:52 EDT
Description of problem: When I install quick-start application Lifaray following the instructions on GitHub the app doesn't start properly. Logs are attached.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. Follow the instructions on https://github.com/openshift/jbossas7-liferay-quickstart
  

Actual results: Application doesn't start properly


Expected results: Application must be started successfully


Additional info:
Comment 1 Attila Nagy 2012-07-17 10:21:40 EDT
Created attachment 598653 [details]
server.log
Comment 2 Attila Nagy 2012-07-17 10:22:44 EDT
I tried with ami-2fb61846
Comment 3 Dan McPherson 2012-07-17 10:41:55 EDT
Hi Grant,

  Who owns this one?

Thanks,

Dan
Comment 4 Kamesh Sampath 2012-07-18 12:43:08 EDT
Its me Dan, will try to help as much as I can, since I am the one who developed this quick start.
(In reply to comment #3)
> Hi Grant,
> 
>   Who owns this one?
> 
> Thanks,
> 
> Dan
Comment 5 Kamesh Sampath 2012-07-18 12:48:04 EDT
I also like to know if the DB cartridge has been added to the app ? by default it expects MySql cartridge added to the app.

Any ways thanks for pointing to this i need to ensure that the scenarios without DB (MySql) things should work.

Let me work on a fix and let the community know.

~Kamesh
Comment 6 Kamesh Sampath 2012-07-21 03:10:33 EDT
Hi,

I verified creating the application based on the README.md found at https://github.com/openshift/jbossas7-liferay-quickstart and see the application getting created and started successfully.  I have created two applications

#1 with mysql support 

This one gets started successfully except for the issue that I have mentioned in the Open Issues section 

#with no mysql/posgresql support. 

This will throw the following messsage when you do a git push because of missing $OPENSHIFT_DB_HOST
......
remote: Running .openshift/action_hooks/deploy
remote: 
remote: Could not find mysql database.  Please run:
remote: rhc app cartridge add -a lpdemo2 -c mysql-5.1
remote: then make a sample commit (add whitespace somewhere) and re-push
.....

Even in the above case the server is started without the liferay deployment, as Liferay requires a DB the deployment is skipped via .openshift/action_hooks/deploy script

A liferay portal user can then decide to use the default HSQL db if we wishes to by commenting "jdbc.default.jndi.name" the portal-ext.properties file found in the location specified in README.md

~Kamesh
Comment 7 Kamesh Sampath 2012-07-21 03:13:03 EDT
Created attachment 599491 [details]
Server Logs

The server logs for the application getting started properly with Mysql DB support and log without mysql DB support where the application is not deployed

The live application created and started successfully with mysql DB support is available at http://lpdemo1-workspace7.rhcloud.com/
Comment 8 Kamesh Sampath 2012-07-21 03:31:38 EDT
I have destroyed the application mentioned above (lpdemo1) just to save space for my account
Comment 9 Kamesh Sampath 2012-07-21 12:14:01 EDT
Updated the quick start with bug fixes and postgesql support 

It will be great if the openshift fork could be rebased with 

https://github.com/kameshsampath/jbossas7-liferay-quickstart/tree/1.0.0 (Tag 1.0.0)
Comment 10 Mike McGrath 2012-08-29 14:20:34 EDT
*** Bug 846183 has been marked as a duplicate of this bug. ***
Comment 11 Mike McGrath 2012-08-29 14:20:43 EDT
Bringing more in line with dup bug
Comment 13 Dan McPherson 2013-06-24 15:26:02 EDT
We stopped supporting this quickstart.

Note You need to log in before you can comment on or make changes to this bug.