Bug 840896 - GeoIP package has wrong License
GeoIP package has wrong License
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: GeoIP (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Paul Howarth
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 10:22 EDT by Jan Safranek
Modified: 2012-12-20 11:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:04:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2012-07-17 10:22:51 EDT
md5.c is licensed under GPLv2+ and it seems to be linked at least to libGeoIPUpdate. Therefore everything what links this library must be GPLv2+ too.

Upstream COPYING file mentions this exception.

Version-Release number of selected component (if applicable):
GeoIP-1.4.8-2.1.fc18
Comment 1 Fedora Admin XMLRPC Client 2012-10-22 10:21:09 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Paul Howarth 2012-10-22 11:16:49 EDT
How about I change the package's license tag to "LGPLv2+ and GPLv2+", with most of the package being "LGPLv2+" and just %{_libdir}/libGeoIPUpdate* being "GPLv2+"?

That would reflect upstream's licenses whilst creating minimal impact on the rest of the distribution, since all current GeoIP users in Fedora are linked against libGeoIP but not libGeoIPUpdate.
Comment 3 Fedora Update System 2012-10-22 16:57:24 EDT
GeoIP-1.4.8-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/GeoIP-1.4.8-4.fc18
Comment 4 Fedora Update System 2012-10-23 02:49:00 EDT
Package GeoIP-1.4.8-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GeoIP-1.4.8-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16711/GeoIP-1.4.8-4.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 11:04:29 EST
GeoIP-1.4.8-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.