Bug 840910 - Change resolution to the smallest one and back on monitor connected by VGA causes system freeze
Change resolution to the smallest one and back on monitor connected by VGA ca...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-nouveau (Show other bugs)
7.0
x86_64 Linux
high Severity high
: beta
: 7.0
Assigned To: Ben Skeggs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 10:59 EDT by Martin Simon
Modified: 2016-09-19 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 05:49:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2012-07-17 10:59:19 EDT
Description of problem:
It causes on my ThinkPad T410 with nvidia graphic card. I have two monitors connected - one the laptop built-in and the second one by VGA connected 22' Samsung. When change resolution by Control Center - Displays on the second one (Samsung) to the smallest one (800x600) and back to the origin one, the samsung monitor never wake up and the laptops one shows the desktop with some graphic fragments. I can move the mouse but cannot do anything more. Only possible way is to hold power button and shutdown the laptop by force..

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-0.0.16-36.20120306gitf5d1cd2.el7.x86_64
control-center-3.4.2-2.el7.x86_64
gnome-shell-3.4.1-5.el7.x86_64
kernel-3.3.0-0.17.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Have active two displays - one monitor built-in and the second one through VGA
2. Change resolution on the external display to 800x600, confirm by click "Keep this configuration"
3. Change back to the original resolution
  
Actual results:
The resolution should change

Expected results:
System freeze

Additional info:
I was not able to reproduce it using DVI or intel graphic card..
Comment 1 Ben Skeggs 2012-08-02 21:54:38 EDT
Are you able to provide kernel logs from after this issue has occurred?
Comment 2 Martin Simon 2012-08-06 05:49:36 EDT
It seems it's fixed now, I'm not able to reproduce it any more with kernel-3.3.0-0.20.
Closing with resolution CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.