This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 840926 - slow memory leak on modify operations
slow memory leak on modify operations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: slapi-nis (Show other bugs)
6.3
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Nalin Dahyabhai
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 11:40 EDT by Nalin Dahyabhai
Modified: 2013-02-21 04:50 EST (History)
2 users (show)

See Also:
Fixed In Version: slapi-nis-0.40-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:50:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2012-07-17 11:40:39 EDT
The plugin leaks memory during modify operations because it mistakenly assumes that slapi_mods_add_smod() takes ownership of the Slapi_Mod structure which is passed to it, when it really only takes ownership of the structure's contents.  The bug was fixed in upstream version 0.42, and we can either rebase to pick it up or backport the fix, as it's not an intrusive set of changes.
Comment 3 Namita Soman 2013-01-24 12:36:45 EST
Ran regression tests for IPA. No issues found. Marking this verified - Sanity only
Comment 5 errata-xmlrpc 2013-02-21 04:50:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0370.html

Note You need to log in before you can comment on or make changes to this bug.