This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 840968 - SSL errors when the site certificate contains subjectAltName but DNS is not in it
SSL errors when the site certificate contains subjectAltName but DNS is not i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-httplib2 (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 13:55 EDT by Jeff Abbott
Modified: 2012-08-16 14:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 18:53:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/home/jabbott/Projects/rhsm-web/po/zanata.xml (861 bytes, text/plain)
2012-07-17 13:55 EDT, Jeff Abbott
no flags Details
/home/jabbott/.config/zanata.ini (151 bytes, text/plain)
2012-07-17 13:55 EDT, Jeff Abbott
no flags Details

  None (edit)
Description Jeff Abbott 2012-07-17 13:55:13 EDT
Created attachment 598719 [details]
/home/jabbott/Projects/rhsm-web/po/zanata.xml

Description of problem:

I can't push or pull strings to translate.engineering.redhat.com.


Version-Release number of selected component (if applicable):

zanata-python-client-1.3.7-1.fc16.noarch


How reproducible:

Always.


Steps to Reproduce:
1. zanata push .
2. Get an SSL error.

  
Actual results:

Loading zanata project config from: /home/jabbott/Projects/rhsm-web/po/zanata.xml
Loading zanata user config from: /home/jabbott/.config/zanata.ini
error: [Errno 1] _ssl.c:504: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed


Expected results:

Something involving pushing some updated po files, most likely.


Additional info:

I added the Red Hat CA cert to /etc/pki/tls/certs/ca-bundle.crt, which changed the output and error to:

Loading zanata project config from: /home/jabbott/Projects/rhsm-web/po/zanata.xml
Loading zanata user config from: /home/jabbott/.config/zanata.ini
error: Server presented certificate that does not match host translate.engineering.redhat.com: {'notAfter': 'Mar 23 06:35:43 2013 GMT', 'subjectAltName': (('email', 'eng-ops@redhat.com'),), 'subject': ((('countryName', u'US'),), (('stateOrProvinceName', u'North Carolina'),), (('organizationName', u'Red Hat, Inc.'),), (('organizationalUnitName', u'Engineering Operations'),), (('commonName', u'translate.engineering.redhat.com'),), (('emailAddress', u'eng-ops@redhat.com'),))}
Comment 1 Jeff Abbott 2012-07-17 13:55:46 EDT
Created attachment 598720 [details]
/home/jabbott/.config/zanata.ini
Comment 2 James Ni 2012-07-18 04:10:38 EDT
Hi Jeff

That issue comes from python-httplib2, but even latest python-httplib2 0.7.4-4 still can not deal with Red Hat CA cert, so please update the zanata python client to 1.3.8, and using --disable-ssl-cert option to bypass SSL certs check.
Comment 3 Jeff Abbott 2012-07-19 12:04:05 EDT
Looks like that solved the problem.  Thanks, James!
Comment 4 Ding-Yi Chen 2012-07-23 00:50:54 EDT
Reassign as a bug of python-httplib2
Comment 5 Fedora Update System 2012-07-29 22:33:08 EDT
python-httplib2-0.7.4-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-6.el6
Comment 6 Fedora Update System 2012-07-29 22:34:57 EDT
python-httplib2-0.7.4-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-6.fc16
Comment 7 Fedora Update System 2012-07-29 22:35:16 EDT
python-httplib2-0.7.4-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-6.el5
Comment 8 Fedora Update System 2012-07-29 22:35:36 EDT
python-httplib2-0.7.4-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-6.fc17
Comment 9 Fedora Update System 2012-07-30 13:28:24 EDT
Package python-httplib2-0.7.4-6.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-httplib2-0.7.4-6.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6548/python-httplib2-0.7.4-6.el5
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-09 18:53:54 EDT
python-httplib2-0.7.4-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-08-09 19:06:31 EDT
python-httplib2-0.7.4-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-08-16 13:58:38 EDT
python-httplib2-0.7.4-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-08-16 14:00:46 EDT
python-httplib2-0.7.4-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.