Bug 841005 - Evolution interface stuck when receive first 100 messages
Evolution interface stuck when receive first 100 messages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 16:50 EDT by Mikhail
Modified: 2012-07-24 03:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-24 02:54:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace evolution (8.83 KB, text/plain)
2012-07-17 16:50 EDT, Mikhail
no flags Details
backtrace evolution-calendar-factory (2.73 KB, text/plain)
2012-07-18 13:57 EDT, Mikhail
no flags Details
backtrace evolution-addressbook-factory (1.67 KB, text/plain)
2012-07-18 13:58 EDT, Mikhail
no flags Details
backtrace evolution (17.53 KB, text/plain)
2012-07-18 13:58 EDT, Mikhail
no flags Details
backtrace evolution (10.91 KB, text/plain)
2012-07-19 14:13 EDT, Mikhail
no flags Details
backtrace evolution-calendar-factory (2.97 KB, text/plain)
2012-07-19 14:15 EDT, Mikhail
no flags Details
backtrace evolution-addressbook-factory (1.68 KB, text/plain)
2012-07-19 14:16 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 680502 None None None 2012-07-24 02:54:42 EDT

  None (edit)
Description Mikhail 2012-07-17 16:50:08 EDT
Created attachment 598743 [details]
backtrace evolution

Description of problem:
Evolution interface stuck when receive first 100 messages

Of course demonstration here:https://docs.google.com/open?id=0B0nwzlfiB4aQcC04Y1hxNV9OcWs

And backtrace is attached.
Comment 1 Milan Crha 2012-07-18 07:02:25 EDT
Thanks for a bug report. Evolution is formatting a meeting invitation, and it's opening a calendar. This also requires communication with evolution-calendar-factory process, which seems to be busy with other stuff, thus it doesn't respond in timely manner.

Could you get backtrace of the evolution-calendar-factory process, please?
Comment 2 Mikhail 2012-07-18 13:57:28 EDT
Created attachment 598958 [details]
backtrace evolution-calendar-factory
Comment 3 Mikhail 2012-07-18 13:58:20 EDT
Created attachment 598960 [details]
backtrace evolution-addressbook-factory
Comment 4 Mikhail 2012-07-18 13:58:56 EDT
Created attachment 598961 [details]
backtrace evolution
Comment 5 Milan Crha 2012-07-19 03:23:02 EDT
Thanks for the update. I see the Birthday & Anniversaries calendar is blocking calendar factory in the main thread, waiting for a lock on some place which I do not see in the backtrace, because of missing debuginfo symbols for evolution-data-server. The addressbook factory itself is idle and evolution is waiting on the calendar factory. Could you install debuginfo package for evolution-data-server and get the backtrace of calendar factory again, please? I'll then search upstream bugzilla and move it there.
Comment 6 Mikhail 2012-07-19 14:13:09 EDT
Created attachment 599216 [details]
backtrace evolution
Comment 7 Mikhail 2012-07-19 14:15:15 EDT
Created attachment 599217 [details]
backtrace evolution-calendar-factory
Comment 8 Mikhail 2012-07-19 14:16:13 EDT
Created attachment 599218 [details]
backtrace evolution-addressbook-factory
Comment 9 Milan Crha 2012-07-24 02:54:42 EDT
Thanks for the update. I see that calendar factory is deadlocked in main thread, thus it cannot respond to evolution's requests. I moved this upstream as [1]. Please see [1] for any further updates.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=680502
Comment 10 Milan Crha 2012-07-24 03:14:44 EDT
I'm building eds with upstream patch included at [1]. Please install it.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4324962

Note You need to log in before you can comment on or make changes to this bug.